Read the docs
TI-2024-09934 Aliases CVE-2024-10720GHSA-qgm6-wj98-3qh4

Stored Cross-site Scripting (XSS) in phpipam/phpipam

Priority MEDIUM 60CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

A stored cross-site scripting (XSS) vulnerability exists in phpipam/phpipam version 1.5.2. The vulnerability occurs in the 'Device Management' section under 'Administration' where an attacker can inject malicious scripts into the 'Name' and 'Description' fields when adding a new device type. This can lead to data theft, account compromise, distribution of malware, website defacement, and phishing attacks. The issue is fixed in version 1.7.0.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00393 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed phpipam/phpipam (phpipam): 1.7.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpipamphpipam/phpipambefore 1.7.01.7.0Patch availableCNA
  • phpipam/phpipam Vendorphpipam Affected before 1.7.0 Fixed in 1.7.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:*before 1.7.0Vulnerablephpipam
  • cpe:2.3:a:phpipam:phpipam:*:*:*:*:*:*:*:* Versions before 1.7.0 Vulnerable ·phpipam

Remediation

  • Fix · CNA phpipam/phpipam (phpipam) Fixed in 1.7.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    phpipam/phpipam 1.7.0

    9 records Highest priority Priority HIGH 1 HIGH, 8 MEDIUM

    Other records, highest priority first

    • TI-2024-09932 Cookie without Secure attribute in phpipam/phpipamPriority HIGH 72
    • TI-2024-09941 Cross-Site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 60
    • TI-2024-09939 Stored Cross-site Scripting (XSS) in phpipam/phpipamPriority MEDIUM 58

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-10720
  2. 2026-10-03 Alias added: GHSA-qgm6-wj98-3qh4

References

  • TI-2024-09932 Cookie without Secure attribute in phpipam/phpipam CVSS 3.1HIGH 7.5
  • TI-2023-22036 Phpipam before v1.5.2 was discovered to contain a LDAP injection vulnerability via the… CVSS 3.1HIGH 7.5
  • TI-2023-01145 SQL Injection in phpipam/phpipam CVSS 3.1HIGH 7.2
  • TI-2024-00724 Improper Restriction of Excessive Authentication Attempts in phpipam/phpipam CVSS 3.1MEDIUM 5.9
  • TI-2024-27603 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/powerDNS/record-edit.php. CVSS 3.1HIGH 7.1
  • TI-2024-27600 phpipam 1.6 is vulnerable to Cross Site Scripting (XSS) via /app/admin/widgets/edit.php CVSS 3.1HIGH 7.1
See all 51 →

Sources