WP Job Board Pro < 1.2.85 - Unauthenticated Privilege Escalation via process_register
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Privilege escalation
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-266.
Summary
The WP Job Board Pro plugin for WordPress is vulnerable to privilege escalation in all versions up to 2.3.16. This is due to the plugin allowing a user to supply the 'role' field when registering. This makes it possible for unauthenticated attackers to register as an administrator on vulnerable sites. Please note that this may have been patched sooner, however, the oldest available version for us to confirm this is patched in was 1.2.85.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| http://apusthemes.com/ | WP Job Board Pro | before 1.2.85 | 1.2.85 | Patch available | CNA |
- WP Job Board Pro Vendorhttp://apusthemes.com/ Affected before 1.2.85 Fixed in 1.2.85 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apusthemes:superio:*:*:*:*:*:wordpress:*:* | up to 1.2.76 | Vulnerable | ApusThemes |
- cpe:2.3:a:apusthemes:superio:*:*:*:*:*:wordpress:*:* Versions up to 1.2.76 Vulnerable ·ApusThemes
Remediation
- Fix · CNA WP Job Board Pro (http://apusthemes.com/) Fixed in 1.2.85
Timeline
- 2026-10-02 Threatist record created from CVE-2024-12213
- 2026-10-03 Alias added: GHSA-g989-9gjv-rrfg
- 2026-10-06 EPSS moved to the 50th–90th percentile
References
More ApusThemes Superio vulnerabilities
- TI-2022-03761 Superio - Job Board < 1.2.33 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2024-11406 Apus Framework <= 2.4 - Authenticated (Subscriber+) Arbitrary Options Update in import_page_options CVSS 3.1HIGH 8.8
Sources
- CVE-2024-12213 · CVE Program
- CVE-2024-12213 · NVD
- FIRST EPSS
- GHSA-g989-9gjv-rrfg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences