Booking Package <= 1.6.72 - Reflected Cross-Site Scripting via Locale Parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Booking Package plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the locale parameter in all versions up to, and including, 1.6.72 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| masaakitanaka | Booking Package | up to 1.6.72 | — | No fix listed | CNA |
- Booking Package Vendormasaakitanaka Affected up to 1.6.72 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-13508
- 2026-10-03 Alias added: GHSA-pqvm-49pp-2rp3
References
More masaakitanaka vulnerabilities
- TI-2026-12907 Booking Package <= 1.7.20 - Unauthenticated SQL Injection via 'email' Form Parameter CVSS 3.1HIGH 7.5
- TI-2026-73813 Missing authorization in Booking Package exposes customer data CVSS 3.1HIGH 7.5
- TI-2026-08620 Booking Package <= 1.7.16 - Authenticated (Editor+) Privilege Escalation via Account Takeover to updateUser AJAX Action CVSS 3.1HIGH 7.2
- TI-2026-04281 Booking Package <= 1.7.06 - Unauthenticated Price Manipulation via 'amount' Parameter CVSS 3.1MEDIUM 5.3
- TI-2026-73814 Stored cross-site scripting in Booking Package WordPress plugin CVSS 3.1MEDIUM 6.4
Sources
- CVE-2024-13508 · CVE Program
- CVE-2024-13508 · NVD
- FIRST EPSS
- GHSA-pqvm-49pp-2rp3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences