Booking Package <= 1.7.06 - Unauthenticated Price Manipulation via 'amount' Parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA.
Summary
The Booking Package plugin for WordPress is vulnerable to Price Manipulation in versions up to, and including, 1.7.06 This is due to the intentForStripe() function passing user-controlled $_POST['amount'] directly to the Stripe PaymentIntent API without validation, and the commitStripe() function ignoring the server-calculated amount when confirming the payment. While the server correctly calculates the booking cost via getAmount() based on services, guests, taxes, and coupons, this calculated amount is never validated against or used to update the PaymentIntent because the critical code in CreditCard.php that would include the calculated amount in the PaymentIntent update is commented out. This makes it possible for unauthenticated attackers to book services at arbitrary prices (e.g., $0.01 instead of $500.00) by manipulating the amount parameter during PaymentIntent creation and completing the booking with the fraudulent payment.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| masaakitanaka | Booking Package | up to 1.7.06 | — | No fix listed | CNA |
- Booking Package Vendormasaakitanaka Affected up to 1.7.06 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-4911
- 2026-10-03 Alias added: GHSA-2276-pc6c-j8wg
References
Other 10
- https://www.wordfence.com/threat-intel/vulnerabilities/id/61d63c5a-6ca6-42d8-ab0a-152d9c95945c?source=cve
- https://plugins.trac.wordpress.org/browser/booking-package/trunk/lib/Schedule.php#L8942
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.04/lib/Schedule.php#L8948
- https://plugins.trac.wordpress.org/browser/booking-package/trunk/lib/CreditCard.php#L390
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.04/lib/CreditCard.php#L393
- https://plugins.trac.wordpress.org/browser/booking-package/trunk/lib/CreditCard.php#L545
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.04/lib/CreditCard.php#L548
- https://plugins.trac.wordpress.org/browser/booking-package/trunk/lib/Schedule.php#L15151
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.04/lib/Schedule.php#L15151
- https://plugins.trac.wordpress.org/changeset?old_path=%2Fbooking-package/tags/1.7.06&new_path=%2Fbooking-package/tags/1.7.07
More masaakitanaka vulnerabilities
- TI-2026-12907 Booking Package <= 1.7.20 - Unauthenticated SQL Injection via 'email' Form Parameter CVSS 3.1HIGH 7.5
- TI-2026-73813 Missing authorization in Booking Package exposes customer data CVSS 3.1HIGH 7.5
- TI-2026-08620 Booking Package <= 1.7.16 - Authenticated (Editor+) Privilege Escalation via Account Takeover to updateUser AJAX Action CVSS 3.1HIGH 7.2
- TI-2026-73814 Stored cross-site scripting in Booking Package WordPress plugin CVSS 3.1MEDIUM 6.4
- TI-2024-12549 Booking Package <= 1.6.72 - Reflected Cross-Site Scripting via Locale Parameter CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-4911 · CVE Program
- CVE-2026-4911 · NVD
- FIRST EPSS
- GHSA-2276-pc6c-j8wg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences