Booking Package <= 1.7.20 - Unauthenticated SQL Injection via 'email' Form Parameter
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-89.
Summary
The Booking Package plugin for WordPress is vulnerable to generic SQL Injection via 'email' Form Parameter (form<N>) in all versions up to, and including, 1.7.20 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. The vulnerable REST API endpoint /wp-json/booking-package/v1/request is registered with permission_callback: __return_true and wp_magic_quotes does not apply to REST-sourced $_POST values, meaning single quotes in the payload reach the SQL sink intact without any authentication requirement. The impact of this is severely limited as the vulnerable parameter goes through is_email.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| masaakitanaka | Booking Package | up to 1.7.20 | — | No fix listed | CNA |
- Booking Package Vendormasaakitanaka Affected up to 1.7.20 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2026-15335
- 2026-10-03 Alias added: GHSA-3h3p-33f5-225r
References
Other 10
- https://www.wordfence.com/threat-intel/vulnerabilities/id/8bc86a29-cb1f-4711-925c-51dbbf682477?source=cve
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.18/lib/Schedule.php#L9365
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.20/lib/Schedule.php#L9365
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.20/lib/Schedule.php#L12793
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.20/index.php#L4381
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.20/index.php#L243
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.18/lib/Schedule.php#L12793
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.18/index.php#L4381
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.18/index.php#L243
- https://plugins.trac.wordpress.org/changeset?reponame=&old=3602166%40booking-package&new=3602166%40booking-package
More masaakitanaka vulnerabilities
- TI-2026-73813 Missing authorization in Booking Package exposes customer data CVSS 3.1HIGH 7.5
- TI-2026-08620 Booking Package <= 1.7.16 - Authenticated (Editor+) Privilege Escalation via Account Takeover to updateUser AJAX Action CVSS 3.1HIGH 7.2
- TI-2026-04281 Booking Package <= 1.7.06 - Unauthenticated Price Manipulation via 'amount' Parameter CVSS 3.1MEDIUM 5.3
- TI-2026-73814 Stored cross-site scripting in Booking Package WordPress plugin CVSS 3.1MEDIUM 6.4
- TI-2024-12549 Booking Package <= 1.6.72 - Reflected Cross-Site Scripting via Locale Parameter CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-15335 · CVE Program
- CVE-2026-15335 · NVD
- FIRST EPSS
- GHSA-3h3p-33f5-225r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences