Stored cross-site scripting in Booking Package WordPress plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Booking Package plugin for WordPress through 1.7.29 contains a stored cross-site scripting flaw in the 'id' shortcode attribute (CWE-79) caused by insufficient input sanitization and output escaping. An authenticated attacker with Contributor access or higher can inject scripts into pages that run whenever a user opens the injected page.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Description from the CNA
The Booking Package plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'id' parameter in all versions up to, and including, 1.7.29 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| masaakitanaka | Booking Package | up to 1.7.29 | — | No fix listed | CNA |
- Booking Package Vendormasaakitanaka Affected up to 1.7.29 Fixed in — No fix listed CNA
Remediation
The sources list no fixed version for Booking Package.
Written with Claude Haiku 5.5 from the sources below · 2026-10-28
Timeline
- 2026-10-14 Threatist record created from CVE-2026-103425
- 2026-10-14 Alias added: GHSA-rm22-89fc-8hj5
- 2026-10-14 Priority changed: MEDIUM → LOW
- 2026-10-16 CISA SSVC decision points changed
References
Other 6
- https://www.wordfence.com/threat-intel/vulnerabilities/id/10293e5a-15ea-42c1-a0df-b95f723a75a3?source=cve
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.29/index.php#L1789
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.29/index.php#L1802
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.29/index.php#L1099
- https://plugins.trac.wordpress.org/browser/booking-package/tags/1.7.29/index.php#L260
- https://plugins.trac.wordpress.org/changeset/3728015/booking-package/trunk/index.php
More masaakitanaka vulnerabilities
- TI-2026-12907 Booking Package <= 1.7.20 - Unauthenticated SQL Injection via 'email' Form Parameter CVSS 3.1HIGH 7.5
- TI-2026-73813 Missing authorization in Booking Package exposes customer data CVSS 3.1HIGH 7.5
- TI-2026-08620 Booking Package <= 1.7.16 - Authenticated (Editor+) Privilege Escalation via Account Takeover to updateUser AJAX Action CVSS 3.1HIGH 7.2
- TI-2026-04281 Booking Package <= 1.7.06 - Unauthenticated Price Manipulation via 'amount' Parameter CVSS 3.1MEDIUM 5.3
- TI-2024-12549 Booking Package <= 1.6.72 - Reflected Cross-Site Scripting via Locale Parameter CVSS 3.1MEDIUM 6.1
Sources
- CVE-2026-103425 · CVE Program
- CVE-2026-103425 · NVD
- FIRST EPSS
- GHSA-rm22-89fc-8hj5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences