Stored cross site scripting in Markdown Preview in JupyterLab
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. This vulnerability depends on user interaction by opening a malicious Markdown file using JupyterLab preview feature. A malicious user can access any data that the attacked user has access to as well as perform arbitrary requests acting as the attacked user. JupyterLab version 4.0.11 has been patched. Users are advised to upgrade. Users unable to upgrade should disable the table of contents extension.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jupyterlab | jupyterlab | 4.0.0 to before 4.0.11 | 4.0.11 | Patch available | CNA |
| — | jupyterlab (PyPI) | 4.0.0 to before 4.0.11 | 4.0.11 | Patch available | GHSA-4m77-cmpx-vjc4 |
| — | notebook (PyPI) | 7.0.0 to before 7.0.7 | 7.0.7 | Patch available | GHSA-4m77-cmpx-vjc4 |
- jupyterlab Vendorjupyterlab Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available CNA
- jupyterlab (PyPI) Vendor— Affected 4.0.0 to before 4.0.11 Fixed in 4.0.11 Patch available GHSA-4m77-cmpx-vjc4
- notebook (PyPI) Vendor— Affected 7.0.0 to before 7.0.7 Fixed in 7.0.7 Patch available GHSA-4m77-cmpx-vjc4
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* | 4.0.0 to before 4.0.11 | Vulnerable | jupyterlab |
| cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* | 7.0.0 to before 7.0.7 | Vulnerable | jupyterlab |
| cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* | 39 | Vulnerable | Fedoraproject |
- cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.0.11 Vulnerable ·jupyterlab
- cpe:2.3:a:jupyter:notebook:*:*:*:*:*:*:*:* Versions 7.0.0 to before 7.0.7 Vulnerable ·jupyterlab
- cpe:2.3:o:fedoraproject:fedora:39:*:*:*:*:*:*:* Versions 39 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA jupyterlab (jupyterlab) Fixed in 4.0.11
- Fix · GHSA-4m77-cmpx-vjc4 jupyterlab (PyPI) Fixed in 4.0.11 Advisory →
- Fix · GHSA-4m77-cmpx-vjc4 notebook (PyPI) Fixed in 7.0.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2024-22420
- 2026-10-03 Alias added: GHSA-4m77-cmpx-vjc4
References
Advisory 3
More Jupyterlab vulnerabilities
- TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
- TI-2026-30579 Improper input validation in jupyterlab CVSS 3.1HIGH 8.8
- TI-2021-12463 JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> CVSS 3.1CRITICAL 9.6
- TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
- TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
- TI-2024-29399 HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering CVSS 3.1HIGH 7.6
Sources
- CVE-2024-22420 · CVE Program
- CVE-2024-22420 · NVD
- FIRST EPSS
- GHSA-4m77-cmpx-vjc4 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-22420 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences