Read the docs
TI-2026-30579 Aliases CVE-2026-42266GHSA-37w4-hwhx-4rc4

Improper input validation in jupyterlab

Priority MEDIUM 49CWE-602Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-88.

Summary

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook Architecture. From 4.0.0 to 4.5.6, the allow-list of extensions that can be installed from PyPI Extension Manager (allowed_extensions_uris) is not correctly enforced by JupyterLab. The PyPI Extension Manager was not contained to packages listed on the default PyPI index. This vulnerability is fixed in 4.5.7.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.05652 93rd percentileScored 2026-11-07
Fix Partial jupyterlab (jupyterlab): 4.5.7jupyterlab (PyPI): 4.5.7Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
jupyterlabjupyterlab4.0.0 to before 4.5.74.5.7Patch availableCNA
—jupyterlab (PyPI)4.0.0 to before 4.5.74.5.7Patch availableGHSA-37w4-hwhx-4rc4
  • jupyterlab Vendorjupyterlab Affected 4.0.0 to before 4.5.7 Fixed in 4.5.7 Patch available CNA
  • jupyterlab (PyPI) Vendor— Affected 4.0.0 to before 4.5.7 Fixed in 4.5.7 Patch available GHSA-37w4-hwhx-4rc4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:*4.0.0 to before 4.5.7Vulnerablejupyterlab
  • cpe:2.3:a:jupyter:jupyterlab:*:*:*:*:*:*:*:* Versions 4.0.0 to before 4.5.7 Vulnerable ·jupyterlab

Remediation

  • Fix · CNA jupyterlab (jupyterlab) Fixed in 4.5.7
  • Fix · GHSA-37w4-hwhx-4rc4 jupyterlab (PyPI) Fixed in 4.5.7 Advisory →

Red Hat 2 advisories

  • RHSA-2026:60520 Released 2026-08-27 · Red Hat rating Critical
    RHOAI 3.4.4 - Red Hat OpenShift AI
    • Red Hat OpenShift AI 3.4 registry.redhat.io/rhoai/odh-automl-rhel9, registry.redhat.io/rhoai/odh-autorag-rhel9, registry.redhat.io/rhoai/odh-built-in-detector-rhel9 +47
  • RHSA-2026:43038 Released 2026-07-21 · Red Hat rating Critical
    Migration Toolkit for Applications
    • Red Hat Migration Toolkit for Applications 8.2 registry.redhat.io/mta/mta-cli-rhel9, registry.redhat.io/mta/mta-solution-server-rhel9

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat OpenShift AI (RHOAI)AffectedNo fix yet
Red Hat Migration Toolkit for Applications 8.2Fixed RHSA-2026:43038
Red Hat OpenShift AI 3.4Fixed RHSA-2026:60520
Not affected: 3 products
  • Red Hat Migration Toolkit for Applications 8.2
  • Red Hat OpenShift AI (RHOAI)
  • Red Hat OpenShift AI 3.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2026-42266
  2. 2026-10-03 Alias added: GHSA-37w4-hwhx-4rc4
  3. 2026-10-25 EPSS moved to the 90th–95th percentile

References

  • TI-2024-26623 Remote Code Execution (RCE) vulnerability in jupyterlab extension template `update-integration-tests` GitHub Action CVSS 3.1CRITICAL 10.0
  • TI-2021-12463 JupyterLab: XSS due to lack of sanitization of the action attribute of an html <form> CVSS 3.1CRITICAL 9.6
  • TI-2026-30837 jupyterlab: Command linker attributes in HTML enable one-click command execution from untrusted content CVSS 4.0HIGH 8.6
  • TI-2024-14994 Potential authentication and CSRF tokens leak in JupyterLab CVSS 3.1HIGH 7.6
  • TI-2024-29399 HTML injection in Jupyter Notebook and JupyterLab leading to DOM Clobbering CVSS 3.1HIGH 7.6
  • TI-2024-14993 Stored cross site scripting in Markdown Preview in JupyterLab CVSS 3.1MEDIUM 6.5
See all 7 →

Sources