Read the docs
TI-2024-16180 Aliases CVE-2024-24559GHSA-6845-xw22-ffxv

Vyper SHA3 code generation bug

Priority MEDIUM 57CWE-327Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-327.

Summary

Vyper is a Pythonic Smart Contract Language for the EVM. There is an error in the stack management when compiling the `IR` for `sha3_64`. Concretely, the `height` variable is miscalculated. The vulnerability can't be triggered without writing the `IR` by hand (that is, it cannot be triggered from regular vyper code). `sha3_64` is used for retrieval in mappings. No flow that would cache the `key` was found so the issue shouldn't be possible to trigger when compiling the compiler-generated `IR`. This issue isn't triggered during normal compilation of vyper code so the impact is low. At the time of publication there is no patch available.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00255 17th percentileScored 2026-11-07
Fix Fixed vyper (PyPI): 0.4.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vyperlangvyperup to 0.3.10—No fix listedCNA
—vyper (PyPI)before 0.4.00.4.0Patch availableGHSA-6845-xw22-ffxv
  • vyper Vendorvyperlang Affected up to 0.3.10 Fixed in — No fix listed CNA
  • vyper (PyPI) Vendor— Affected before 0.4.0 Fixed in 0.4.0 Patch available GHSA-6845-xw22-ffxv

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:python:*:*up to 0.3.10Vulnerablevyperlang
  • cpe:2.3:a:vyperlang:vyper:*:*:*:*:*:python:*:* Versions up to 0.3.10 Vulnerable ·vyperlang

Remediation

  • Fix · GHSA-6845-xw22-ffxv vyper (PyPI) Fixed in 0.4.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-24559
  2. 2026-10-03 Alias added: GHSA-6845-xw22-ffxv

References

  • TI-2024-16182 Vyper bounds check on built-in `slice()` function can be overflowed CVSS 3.1CRITICAL 9.8
  • TI-2024-14992 concat built-in can corrupt memory in vyper CVSS 3.1CRITICAL 9.8
  • TI-2024-16184 Vyper array negative index vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2022-08657 Integer bounds error in Vyper CVSS 3.1CRITICAL 9.8
  • TI-2022-11796 Multiple evaluation of contract address in call in vyper CVSS 3.1HIGH 8.2
  • TI-2024-21531 vyper performs double eval of the argument of sqrt CVSS 3.1MEDIUM 5.3
See all 37 →

Sources