Read the docs
TI-2024-16289 Aliases CVE-2024-24772GHSA-m6jm-3v38-76j4

Apache Superset: Improper Neutralisation of custom SQL on embedded context

Priority LOW 22CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
SQL injection
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

A guest user could exploit a chart data REST API and send arbitrary SQL statements that on error could leak information from the underlying analytics database.This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00953 61st percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 3.0.4, 3.1.1apache-superset (PyPI): 3.0.4, 3.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetbefore 3.0.4; 3.1.0 to before 3.1.13.0.4, 3.1.1Patch availableCNA
—apache-superset (PyPI)before 3.0.43.0.4Patch availableGHSA-m6jm-3v38-76j4
—apache-superset (PyPI)3.1.0 to before 3.1.13.1.1Patch availableGHSA-m6jm-3v38-76j4
  • Apache Superset VendorApache Affected before 3.0.4; 3.1.0 to before 3.1.1 Fixed in 3.0.4, 3.1.1 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 3.0.4 Fixed in 3.0.4 Patch available GHSA-m6jm-3v38-76j4
  • apache-superset (PyPI) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-m6jm-3v38-76j4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 3.0.4; 3.1.0 to before 3.1.1VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 3.0.4; 3.1.0 to before 3.1.1 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 3.0.4, 3.1.1
  • Fix · GHSA-m6jm-3v38-76j4 apache-superset (PyPI) Fixed in 3.0.4 Advisory →
  • Fix · GHSA-m6jm-3v38-76j4 apache-superset (PyPI) Fixed in 3.1.1 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Superset 3.0.4, 3.1.1

    5 records Highest priority Priority LOW 5 LOW

    Other records, highest priority first

    • TI-2024-16296 Apache Superset: Improper data authorization when creating a new datasetPriority LOW 30
    • TI-2024-16290 Apache Superset: Improper validation of SQL statements allows for unauthorized access to dataPriority LOW 30
    • TI-2024-17113 Apache Superset: Improper authorization validation on dashboards and charts importPriority LOW 26

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-24772
  2. 2026-10-03 Alias added: GHSA-m6jm-3v38-76j4

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources