Apache Superset: Improper error handling on alerts
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-209.
Summary
An authenticated user with privileges to create Alerts on Alerts & Reports has the capability to generate a specially crafted SQL statement that triggers an error on the database. This error is not properly handled by Apache Superset and may inadvertently surface in the error log of the Alert exposing possibly sensitive data. This issue affects Apache Superset: before 3.0.4, from 3.1.0 before 3.1.1. Users are recommended to upgrade to version 3.1.1 or 3.0.4, which fixes the issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 3.0.4; 3.1.0 to before 3.1.1 | 3.0.4, 3.1.1 | Patch available | CNA |
| — | apache-superset (PyPI) | before 3.0.4 | 3.0.4 | Patch available | GHSA-h7r6-8qmm-hj5r |
| — | apache-superset (PyPI) | 3.1.0 to before 3.1.1 | 3.1.1 | Patch available | GHSA-h7r6-8qmm-hj5r |
- Apache Superset VendorApache Affected before 3.0.4; 3.1.0 to before 3.1.1 Fixed in 3.0.4, 3.1.1 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 3.0.4 Fixed in 3.0.4 Patch available GHSA-h7r6-8qmm-hj5r
- apache-superset (PyPI) Vendor— Affected 3.1.0 to before 3.1.1 Fixed in 3.1.1 Patch available GHSA-h7r6-8qmm-hj5r
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 3.0.4, 3.1.1
- Fix · GHSA-h7r6-8qmm-hj5r apache-superset (PyPI) Fixed in 3.0.4 Advisory →
- Fix · GHSA-h7r6-8qmm-hj5r apache-superset (PyPI) Fixed in 3.1.1 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apache Superset 3.0.4, 3.1.1
5 records Highest priority Priority LOW 5 LOW
Other records, highest priority first
- TI-2024-16296 Apache Superset: Improper data authorization when creating a new datasetPriority LOW 30
- TI-2024-16290 Apache Superset: Improper validation of SQL statements allows for unauthorized access to dataPriority LOW 30
- TI-2024-17113 Apache Superset: Improper authorization validation on dashboards and charts importPriority LOW 26
Timeline
- 2026-10-02 Threatist record created from CVE-2024-27315
- 2026-10-03 Alias added: GHSA-h7r6-8qmm-hj5r
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-27315 · CVE Program
- CVE-2024-27315 · NVD
- FIRST EPSS
- GHSA-h7r6-8qmm-hj5r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences