Apache Superset: Incorrect datasource authorization on explore REST API
Priority LOW 21CWE-863Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.
Summary
An authenticated user could potentially access metadata for a datasource they are not authorized to view by submitting a targeted REST API request.This issue affects Apache Superset: before 3.1.2. Users are recommended to upgrade to version 3.1.2 or above, which fixes the issue.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00705 53rd percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 3.1.2apache-superset (PyPI): 3.1.2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Superset | before 3.1.2 | 3.1.2 | Patch available | CNA |
| — | apache-superset (PyPI) | before 3.1.2 | 3.1.2 | Patch available | GHSA-299q-3p96-5898 |
- Apache Superset VendorApache Affected before 3.1.2 Fixed in 3.1.2 Patch available CNA
- apache-superset (PyPI) Vendor— Affected before 3.1.2 Fixed in 3.1.2 Patch available GHSA-299q-3p96-5898
Remediation
- Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 3.1.2
- Fix · GHSA-299q-3p96-5898 apache-superset (PyPI) Fixed in 3.1.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-28148
- 2026-10-03 Alias added: GHSA-299q-3p96-5898
References
More Apache Superset vulnerabilities
- TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
- TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
- TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
- TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
- TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
- TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
Sources
- CVE-2024-28148 · CVE Program
- CVE-2024-28148 · NVD
- FIRST EPSS
- GHSA-299q-3p96-5898 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences