WordPress Restaurant Menu and Food Ordering plugin <= 2.4.14 - Cross Site Scripting (XSS) vulnerability
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Five Star Plugins Five Star Restaurant Menu allows Stored XSS.This issue affects Five Star Restaurant Menu: from n/a through 2.4.14.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0032 25th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Five Star Plugins | Five Star Restaurant Menu | up to 2.4.14 | — | No fix listed | CNA |
- Five Star Restaurant Menu VendorFive Star Plugins Affected up to 2.4.14 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-29089
- 2026-10-03 Alias added: GHSA-r827-xvqc-w2g2
More Five Star Plugins vulnerabilities
- TI-2023-04913 Five Star Restaurant Menu and Food Ordering < 2.4.11 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2020-17543 The food-and-drink-menu plugin through 2.2.0 for WordPress allows remote attackers to… CVSS 3.1CRITICAL 9.8
- TI-2022-00345 Five Star Restaurant Reservations < 2.4.12 - Unauthenticated Arbitrary Payment Status Update to Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-19417 WordPress Five Star Restaurant Menu Plugin <= 2.4.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-16883 WordPress Five Star Restaurant Reservations Plugin <= 2.6.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-22183 WordPress Five Star Restaurant Reservations plugin <= 2.6.16 - Broken Access Control vulnerability CVSS 3.1MEDIUM 5.3
Sources
- CVE-2024-29089 · CVE Program
- CVE-2024-29089 · NVD
- FIRST EPSS
- GHSA-r827-xvqc-w2g2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences