WordPress Five Star Restaurant Reservations plugin <= 2.6.16 - Broken Access Control vulnerability
Priority LOW 30CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
Missing Authorization vulnerability in Five Star Plugins Five Star Restaurant Reservations.This issue affects Five Star Restaurant Reservations: from n/a through 2.6.16.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00381 32nd percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Five Star Plugins | Five Star Restaurant Reservations | up to 2.6.16 | — | No fix listed | CNA |
- Five Star Restaurant Reservations VendorFive Star Plugins Affected up to 2.6.16 Fixed in — No fix listed CNA
CPE names CISA-ADP · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:-:*:*:*:*:wordpress:*:* | not specified by CISA-ADP | — | Five Star Plugins |
- cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:-:*:*:*:*:wordpress:*:* Versions not specified by CISA-ADP — ·Five Star Plugins
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2024-33596
- 2026-10-03 Alias added: GHSA-8f29-7cmc-83vw
More Five Star Plugins vulnerabilities
- TI-2023-04913 Five Star Restaurant Menu and Food Ordering < 2.4.11 - Unauthenticated PHP Object Injection CVSS 3.1CRITICAL 9.8
- TI-2020-17543 The food-and-drink-menu plugin through 2.2.0 for WordPress allows remote attackers to… CVSS 3.1CRITICAL 9.8
- TI-2022-00345 Five Star Restaurant Reservations < 2.4.12 - Unauthenticated Arbitrary Payment Status Update to Stored XSS CVSS 3.1MEDIUM 6.1
- TI-2023-19417 WordPress Five Star Restaurant Menu Plugin <= 2.4.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-16883 WordPress Five Star Restaurant Reservations Plugin <= 2.6.7 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2024-19263 WordPress Restaurant Menu and Food Ordering plugin <= 2.4.14 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2024-33596 · CVE Program
- CVE-2024-33596 · NVD
- FIRST EPSS
- GHSA-8f29-7cmc-83vw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences