An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute…
Priority HIGH 70CWE-94Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- Low · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
An issue in FlowiseAI Inc Flowise v.1.6.2 and before allows a remote attacker to execute arbitrary code via a crafted script to the api/v1 component.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.59867 99th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed flowise (npm): 1.8.1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | flowise (npm) | before 1.8.1 | 1.8.1 | Patch available | GHSA-6wp6-22x5-rr3w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- flowise (npm) Vendor— Affected before 1.8.1 Fixed in 1.8.1 Patch available GHSA-6wp6-22x5-rr3w
Remediation
- Fix · GHSA-6wp6-22x5-rr3w flowise (npm) Fixed in 1.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-31621
- 2026-10-03 Alias added: GHSA-6wp6-22x5-rr3w
References
More FlowiseAI Flowise vulnerabilities
- TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
- TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
- TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
- TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
- TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
Sources
- CVE-2024-31621 · CVE Program
- CVE-2024-31621 · NVD
- FIRST EPSS
- GHSA-6wp6-22x5-rr3w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences