WordPress Slider Revolution plugin < 6.7.11 - Cross Site Scripting (XSS) vulnerability
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in ThemePunch OHG Slider Revolution allows Stored XSS.This issue affects Slider Revolution: from n/a before 6.7.11.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00281 20th percentileScored 2026-11-07
Fix Fixed Slider Revolution (ThemePunch OHG): 6.7.11
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Revolution Slider | Slider Revolution | before 6.7.11 | 6.7.11 | Patch available | CNA |
- Slider Revolution VendorRevolution Slider Affected before 6.7.11 Fixed in 6.7.11 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:* | before 6.7.11 | Vulnerable | Revolution Slider |
- cpe:2.3:a:themepunch:slider_revolution:*:*:*:*:*:wordpress:*:* Versions before 6.7.11 Vulnerable ·Revolution Slider
Remediation
- Fix · CNA Slider Revolution (ThemePunch OHG) Fixed in 6.7.11
Timeline
- 2026-10-02 Threatist record created from CVE-2024-34443
- 2026-10-03 Alias added: GHSA-9267-jhp8-82jg
References
More Revolution Slider Slider Revolution vulnerabilities
- TI-2023-05983 Slider Revolution < 6.6.19 - Author+ Insecure Deserialization leading to RCE CVSS 3.1HIGH 8.8
- TI-2023-02214 Revolution Slider <= 6.6.12 - Author+ Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2014-07914 The ThemePunch Slider Revolution (revslider) plugin before 3.0.96 for WordPress and… CVSS 2.0HIGH 7.5
- TI-2014-07913 Directory traversal vulnerability in the Slider Revolution (revslider) plugin before 4.2… CVSS 2.0MEDIUM 5.0
- TI-2023-25894 WordPress Slider Revolution Plugin <= 6.6.15 is vulnerable to Arbitrary File Upload CVSS 3.1HIGH 8.8
- TI-2024-22779 WordPress Slider Revolution plugin < 6.7.0 - Unauthenticated Broken Access Control vulnerability CVSS 3.1HIGH 8.8
Sources
- CVE-2024-34443 · CVE Program
- CVE-2024-34443 · NVD
- FIRST EPSS
- GHSA-9267-jhp8-82jg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences