Read the docs
TI-2024-23012 Aliases CVE-2024-34715GHSA-8cm5-jfj2-26q7

Partial Password Exposure Vulnerability in Fides Webserver Logs

Priority LOW 16CWE-116Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-532.

Summary

Fides is an open-source privacy engineering platform. The Fides webserver requires a connection to a hosted PostgreSQL database for persistent storage of application data. If the password used by the webserver for this database connection includes special characters such as `@` and `$`, webserver startup fails and the part of the password following the special character is exposed in webserver error logs. This is caused by improper escaping of the SQLAlchemy password string. As a result users are subject to a partial exposure of hosted database password in webserver logs. The vulnerability has been patched in Fides version `2.37.0`. Users are advised to upgrade to this version or later to secure their systems against this threat. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00275 20th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed fides (ethyca): 2.37.0ethyca-fides (PyPI): 2.37.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ethycafidesbefore 2.37.02.37.0Patch availableCNA
—ethyca-fides (PyPI)before 2.37.02.37.0Patch availableGHSA-8cm5-jfj2-26q7
  • fides Vendorethyca Affected before 2.37.0 Fixed in 2.37.0 Patch available CNA
  • ethyca-fides (PyPI) Vendor— Affected before 2.37.0 Fixed in 2.37.0 Patch available GHSA-8cm5-jfj2-26q7

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:*before 2.37.0Vulnerableethyca
  • cpe:2.3:a:ethyca:fides:*:*:*:*:*:*:*:* Versions before 2.37.0 Vulnerable ·ethyca

Remediation

  • Fix · CNA fides (ethyca) Fixed in 2.37.0
  • Fix · GHSA-8cm5-jfj2-26q7 ethyca-fides (PyPI) Fixed in 2.37.0 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-34715
  2. 2026-10-03 Alias added: GHSA-8cm5-jfj2-26q7

References

  • TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
  • TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
  • TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
  • TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
  • TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
See all 19 →

Sources