Inclusion of Untrusted polyfill.io Code Vulnerability in fides.js
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
Fides is an open-source privacy engineering platform. `fides.js`, a client-side script used to interact with the consent management features of Fides, used the `polyfill.io` domain in a very limited edge case, when it detected a legacy browser such as IE11 that did not support the fetch standard. Therefore it was possible for users of legacy, pre-2017 browsers who navigate to a page serving `fides.js` to download and execute malicious scripts from the `polyfill.io` domain when the domain was compromised and serving malware. No exploitation of `fides.js` via `polyfill.io` has been identified as of time of publication. The vulnerability has been patched in Fides version `2.39.1`. Users are advised to upgrade to this version or later to secure their systems against this threat. On Thursday, June 27, 2024, Cloudflare and Namecheap intervened at a domain level to ensure `polyfill.io` and its subdomains could not resolve to the compromised service, rendering this vulnerability unexploitable. Prior to the domain level intervention, there were no server-side workarounds and the confidentiality, integrity, and availability impacts of this vulnerability were high. Clients could ensure they were not affected by using a modern browser that supported the fetch standard.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ethyca | fides | before 2.39.1 | 2.39.1 | Patch available | CNA |
| — | ethyca-fides (PyPI) | before 2.39.1 | 2.39.1 | Patch available | GHSA-cvw4-c69g-7v7m |
- fides Vendorethyca Affected before 2.39.1 Fixed in 2.39.1 Patch available CNA
- ethyca-fides (PyPI) Vendor— Affected before 2.39.1 Fixed in 2.39.1 Patch available GHSA-cvw4-c69g-7v7m
Remediation
- Fix · CNA fides (ethyca) Fixed in 2.39.1
- Fix · GHSA-cvw4-c69g-7v7m ethyca-fides (PyPI) Fixed in 2.39.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-38537
- 2026-10-03 Alias added: GHSA-cvw4-c69g-7v7m
References
Patch 3
More ethyca Fides vulnerabilities
- TI-2024-30165 Remote Code Execution Vulnerability via SSTI in Fides Webserver Jinja Email Templating Engine CVSS 3.1CRITICAL 9.1
- TI-2024-30164 Fides Webserver Authentication Timing-Based Username Enumeration Vulnerability CVSS 3.1MEDIUM 5.3
- TI-2024-20599 Fides Information Disclosure Vulnerability in Privacy Center of SERVER_SIDE_FIDES_API_URL CVSS 3.1MEDIUM 5.3
- TI-2024-23262 Sensitive Data Disclosure Vulnerability in Connection Configuration Endpoints in Fides CVSS 3.1MEDIUM 6.5
- TI-2023-26088 Cryptographically Weak Generation of One-Time Codes for Identity Verification in ethyca-fides CVSS 3.1CRITICAL 9.1
- TI-2025-35700 Fides Webserver API is Vulnerable to OAuth Client Privilege Escalation CVSS 4.0HIGH 8.6
Sources
- CVE-2024-38537 · CVE Program
- CVE-2024-38537 · NVD
- FIRST EPSS
- GHSA-cvw4-c69g-7v7m · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences