PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via style information
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. In affected versions `\PhpOffice\PhpSpreadsheet\Writer\Html` doesn't sanitize spreadsheet styling information such as font names, allowing an attacker to inject arbitrary JavaScript on the page. As a result an attacker may used a crafted spreadsheet to fully takeover a session of a user viewing spreadsheet files as HTML. This issue has been addressed in release version 2.1.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | before 2.1.0 | 2.1.0 | Patch available | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.0 | 2.1.0 | Patch available | GHSA-wgmf-q9vr-vww6 |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.29.1 | 1.29.1 | Patch available | GHSA-wgmf-q9vr-vww6 |
| — | phpoffice/phpexcel (Packagist) | up to 1.8.2 | — | No fix listed | GHSA-wgmf-q9vr-vww6 |
- PhpSpreadsheet VendorPHPOffice Affected before 2.1.0 Fixed in 2.1.0 Patch available CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.0 Fixed in 2.1.0 Patch available GHSA-wgmf-q9vr-vww6
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.1 Fixed in 1.29.1 Patch available GHSA-wgmf-q9vr-vww6
- phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-wgmf-q9vr-vww6
Remediation
- Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 2.1.0
- Fix · GHSA-wgmf-q9vr-vww6 phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.0 Advisory →
- Fix · GHSA-wgmf-q9vr-vww6 phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2024-45046
- 2026-10-03 Alias added: GHSA-wgmf-q9vr-vww6
References
Patch 2
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
Sources
- CVE-2024-45046 · CVE Program
- CVE-2024-45046 · NVD
- FIRST EPSS
- GHSA-wgmf-q9vr-vww6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences