Read the docs
TI-2024-30362 Aliases CVE-2024-45290GHSA-5gpr-w2p5-6m37

Path traversal and Server-Side Request Forgery when opening XLSX files in PHPSpreadsheet

Priority HIGH 67CWE-36Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-918 and the CVSS impact.

Summary

PHPSpreadsheet is a pure PHP library for reading and writing spreadsheet files. It's possible for an attacker to construct an XLSX file which links media from external URLs. When opening the XLSX file, PhpSpreadsheet retrieves the image size and type by reading the file contents, if the provided path is a URL. By using specially crafted `php://filter` URLs an attacker can leak the contents of any file or URL. Note that this vulnerability is different from GHSA-w9xv-qf98-ccq4, and resides in a different component. An attacker can access any file on the server, or leak information form arbitrary URLs, potentially exposing sensitive information such as AWS IAM credentials. This issue has been addressed in release versions 1.29.2, 2.1.1, and 2.3.0. All users are advised to upgrade. There are no known workarounds for this vulnerability.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00625 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PhpSpreadsheet (PHPOffice): 1.29.2, 2.1.1, 2.3.0phpoffice/phpspreadsheet (Packagist): 2.3.0, 1.29.2, 2.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPOfficePhpSpreadsheetbefore 1.29.2; 2.0.0 to before 2.1.1; 2.2.0 to before 2.3.01.29.2, 2.1.1, 2.3.0Patch availableCNA
—phpoffice/phpspreadsheet (Packagist)2.2.0 to before 2.3.02.3.0Patch availableGHSA-5gpr-w2p5-6m37
—phpoffice/phpspreadsheet (Packagist)before 1.29.21.29.2Patch availableGHSA-5gpr-w2p5-6m37
—phpoffice/phpspreadsheet (Packagist)2.0.0 to before 2.1.12.1.1Patch availableGHSA-5gpr-w2p5-6m37
—phpoffice/phpexcel (Packagist)up to 1.8.2—No fix listedGHSA-5gpr-w2p5-6m37
  • PhpSpreadsheet VendorPHPOffice Affected before 1.29.2; 2.0.0 to before 2.1.1; 2.2.0 to before 2.3.0 Fixed in 1.29.2, 2.1.1, 2.3.0 Patch available CNA
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.3.0 Fixed in 2.3.0 Patch available GHSA-5gpr-w2p5-6m37
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.2 Fixed in 1.29.2 Patch available GHSA-5gpr-w2p5-6m37
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-5gpr-w2p5-6m37
  • phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-5gpr-w2p5-6m37

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*before 1.29.2; 2.0.0 to before 2.1.1; 2.2.0 to before 2.3.0VulnerablePHPOffice
  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.29.2; 2.0.0 to before 2.1.1; 2.2.0 to before 2.3.0 Vulnerable ·PHPOffice

Remediation

  • Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 1.29.2, 2.1.1, 2.3.0
  • Fix · GHSA-5gpr-w2p5-6m37 phpoffice/phpspreadsheet (Packagist) Fixed in 2.3.0 Advisory →
  • Fix · GHSA-5gpr-w2p5-6m37 phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.2 Advisory →
  • Fix · GHSA-5gpr-w2p5-6m37 phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.1 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-45290
  2. 2026-10-03 Alias added: GHSA-5gpr-w2p5-6m37
  3. 2026-10-31 EPSS moved to the 50th–90th percentile
  4. 2026-11-02 EPSS moved to the below the 50th percentile
  5. 2026-11-03 EPSS moved to the 50th–90th percentile

References

  • TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
  • TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
  • TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
  • TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
  • TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
  • TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
See all 24 →

Sources