Incorrect default permissions in Jenkins Pipeline: Declarative Plugin
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-285.
Summary
Jenkins Pipeline: Declarative Plugin 2.2214.vb_b_34b_2ea_9b_83 and earlier does not check whether the main (Jenkinsfile) script used to restart a build from a specific stage is approved, allowing attackers with Item/Build permission to restart a previous build whose (Jenkinsfile) script is no longer approved.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Pipeline: Declarative Plugin | up to 2.2214.vb_b_34b_2ea_9b_83 | — | No fix listed | CNA |
| — | org.jenkinsci.plugins:pipeline-model-parent (Maven) | before 2.2218.v56d0cda | 2.2218.v56d0cda | Patch available | GHSA-p2qq-c693-q53w |
- Jenkins Pipeline: Declarative Plugin VendorJenkins Affected up to 2.2214.vb_b_34b_2ea_9b_83 Fixed in — No fix listed CNA
- org.jenkinsci.plugins:pipeline-model-parent (Maven) Vendor— Affected before 2.2218.v56d0cda Fixed in 2.2218.v56d0cda Patch available GHSA-p2qq-c693-q53w
Remediation
- Fix · GHSA-p2qq-c693-q53w org.jenkinsci.plugins:pipeline-model-parent (Maven) Fixed in 2.2218.v56d0cda Advisory →
Red Hat 6 advisories
- RHSA-2025:2223 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.12 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.12 jenkins-2-plugins-4.12.1740464689-1.el8, jenkins-2.479.3.1740464431-3.el8
- RHSA-2025:2221 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.14 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.14 jenkins-2-plugins-4.14.1740109868-1.el8, jenkins-2.479.3.1740109575-3.el8
- RHSA-2025:2220 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.15 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.15 jenkins-2-plugins-4.15.1740052174-1.el8, jenkins-2.479.3.1740051993-3.el8
Show 3 more Red Hat advisories
- RHSA-2025:2218 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.17 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.17 jenkins-2-plugins-4.17.1739859908-1.el9, jenkins-2.479.3.1739859586-3.el9
- RHSA-2025:2222 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.13 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.13 jenkins-2-plugins-4.13.1740464698-1.el8, jenkins-2.479.3.1740464433-3.el8
- RHSA-2025:2219 Released 2025-03-04 · Red Hat rating ImportantRed Hat Product OCP Tools 4.16 Openshift Jenkins security update
- OpenShift Developer Tools and Services for OCP 4.16 jenkins-2-plugins-4.16.1739896683-1.el9, jenkins-2.479.3.1739896390-3.el9
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Developer Tools and Services for OCP 4.12 | Fixed | RHSA-2025:2223 |
| OpenShift Developer Tools and Services for OCP 4.13 | Fixed | RHSA-2025:2222 |
| OpenShift Developer Tools and Services for OCP 4.14 | Fixed | RHSA-2025:2221 |
| OpenShift Developer Tools and Services for OCP 4.15 | Fixed | RHSA-2025:2220 |
| OpenShift Developer Tools and Services for OCP 4.16 | Fixed | RHSA-2025:2219 |
| OpenShift Developer Tools and Services for OCP 4.17 | Fixed | RHSA-2025:2218 |
Timeline
- 2026-10-02 Threatist record created from CVE-2024-52551
- 2026-10-03 Alias added: GHSA-p2qq-c693-q53w
References
More Jenkins Pipeline vulnerabilities
- TI-2019-15875 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin KEVCVSS 3.1CRITICAL 9.9
- TI-2019-15846 A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.61 and earlier in… CVSS 3.1HIGH 8.8
- TI-2019-15847 A sandbox bypass vulnerability exists in Pipeline: Declarative Plugin 1.3.3 and earlier… CVSS 3.1HIGH 8.8
- TI-2023-11034 Cross-site scripting in Jenkins Pipeline: Build Step Plugin CVSS 3.1MEDIUM 5.4
- TI-2019-15886 A sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin 2.64 and earlier allows… CVSS 3.1CRITICAL 9.8
- TI-2022-21197 Protection mechanism failure in Jenkins Pipeline: Groovy Plugin CVSS 3.1CRITICAL 9.9
Sources
- CVE-2024-52551 · CVE Program
- CVE-2024-52551 · NVD
- FIRST EPSS
- GHSA-p2qq-c693-q53w · GitHub Advisory Database · CC BY 4.0
- CVE-2024-52551 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences