Read the docs
TI-2024-36111 Aliases CVE-2024-53947GHSA-92qf-8gh3-gwcm

Apache Superset: Improper SQL authorisation, parse not checking for specific postgres functions

Priority LOW 14CWE-89Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
Present
Impact type
SQL injection
Confidentiality · integrity · availability
Low · None · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.

Summary

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Superset. Specifically, certain engine-specific functions are not checked, which allows attackers to bypass Apache Superset's SQL authorization. This issue is a follow-up to CVE-2024-39887 with additional disallowed PostgreSQL functions now included: query_to_xml_and_xmlschema, table_to_xml, table_to_xml_and_xmlschema. This issue affects Apache Superset: <4.1.0. Users are recommended to upgrade to version 4.1.0, which fixes the issue or add these Postgres functions to the config set DISALLOWED_SQL_FUNCTIONS.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00836 57th percentileScored 2026-11-07
Fix Fixed Apache Superset (Apache Software Foundation): 4.1.0apache-superset (PyPI): 4.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetbefore 4.1.04.1.0Patch availableCNA
—apache-superset (PyPI)before 4.1.04.1.0Patch availableGHSA-92qf-8gh3-gwcm
  • Apache Superset VendorApache Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA
  • apache-superset (PyPI) Vendor— Affected before 4.1.0 Fixed in 4.1.0 Patch available GHSA-92qf-8gh3-gwcm

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 4.1.0VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 4.1.0 Vulnerable ·Apache

Remediation

  • Fix · CNA Apache Superset (Apache Software Foundation) Fixed in 4.1.0
  • Fix · GHSA-92qf-8gh3-gwcm apache-superset (PyPI) Fixed in 4.1.0 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Apache Superset 4.1.0

    3 records Highest priority Priority LOW 3 LOW

    Other records, highest priority first

    • TI-2024-36113 Apache Superset: Lower privilege users are able to create Role when FAB_ADD_SECURITY_API is enabledPriority LOW 36
    • TI-2024-36112 Apache Superset: Error verbosity exposes metadata in analytics databasesPriority LOW 26

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-53947
  2. 2026-10-03 Alias added: GHSA-92qf-8gh3-gwcm

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources