Next.js Vulnerable to Denial of Service (DoS) with Server Actions
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · Low
- Fix status
- Partial Red Hat: 1 fixed, 4 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
Next.js is a React framework for building full-stack web applications. Starting in version 13.0.0 and prior to versions 13.5.8, 14.2.21, and 15.1.2, Next.js is vulnerable to a Denial of Service (DoS) attack that allows attackers to construct requests that leaves requests to Server Actions hanging until the hosting provider cancels the function execution. This vulnerability can also be used as a Denial of Wallet (DoW) attack when deployed in providers billing by response times. (Note: Next.js server is idle during that time and only keeps the connection open. CPU and memory footprint are low during that time.). Deployments without any protection against long running Server Action invocations are especially vulnerable. Hosting providers like Vercel or Netlify set a default maximum duration on function execution to reduce the risk of excessive billing. This is the same issue as if the incoming HTTP request has an invalid `Content-Length` header or never closes. If the host has no other mitigations to those then this vulnerability is novel. This vulnerability affects only Next.js deployments using Server Actions. The issue was resolved in Next.js 13.5.8, 14.2.21, and 15.1.2. We recommend that users upgrade to a safe version. There are no official workarounds.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 13.0.0 to before 13.5.8; 14.0.0 to before 14.2.21; 15.0.0 to before 15.1.2 | 13.5.8, 14.2.21, 15.1.2 | Patch available | CNA |
| — | next (npm) | 13.0.0 to before 13.5.8 | 13.5.8 | Patch available | GHSA-7m27-7ghc-44w9 |
| — | next (npm) | 14.0.0 to before 14.2.21 | 14.2.21 | Patch available | GHSA-7m27-7ghc-44w9 |
| — | next (npm) | 15.0.0 to before 15.1.2 | 15.1.2 | Patch available | GHSA-7m27-7ghc-44w9 |
- next.js Vendorvercel Affected 13.0.0 to before 13.5.8; 14.0.0 to before 14.2.21; 15.0.0 to before 15.1.2 Fixed in 13.5.8, 14.2.21, 15.1.2 Patch available CNA
- next (npm) Vendor— Affected 13.0.0 to before 13.5.8 Fixed in 13.5.8 Patch available GHSA-7m27-7ghc-44w9
- next (npm) Vendor— Affected 14.0.0 to before 14.2.21 Fixed in 14.2.21 Patch available GHSA-7m27-7ghc-44w9
- next (npm) Vendor— Affected 15.0.0 to before 15.1.2 Fixed in 15.1.2 Patch available GHSA-7m27-7ghc-44w9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* | 13.0.0 to before 13.5.8; 14.0.0 to before 14.2.21; 15.0.0 to before 15.1.2 | Vulnerable | vercel |
- cpe:2.3:a:vercel:next.js:*:*:*:*:*:node.js:*:* Versions 13.0.0 to before 13.5.8; 14.0.0 to before 14.2.21; 15.0.0 to before 15.1.2 Vulnerable ·vercel
Remediation
- Fix · CNA next.js (vercel) Fixed in 13.5.8, 14.2.21, 15.1.2
- Fix · GHSA-7m27-7ghc-44w9 next (npm) Fixed in 13.5.8 Advisory →
- Fix · GHSA-7m27-7ghc-44w9 next (npm) Fixed in 14.2.21 Advisory →
- Fix · GHSA-7m27-7ghc-44w9 next (npm) Fixed in 15.1.2 Advisory →
Red Hat 1 advisory
- RHSA-2025:3807 Released 2025-04-10 · Red Hat rating ModerateRHTAS 1.1.2 - Red Hat Trusted Artifact Signer Release
- Red Hat Trusted Artifact Signer 1.1 registry.redhat.io/rhtas/rekor-search-ui-rhel9
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix planned: Out of support scope |
| streams for Apache Kafka | Affected | No fix yet |
| Red Hat Trusted Artifact Signer 1.1 | Fixed | RHSA-2025:3807 |
Not affected: 1 product
- Red Hat Enterprise Linux 9
Timeline
- 2026-10-02 Threatist record created from CVE-2024-56332
- 2026-10-03 Alias added: GHSA-7m27-7ghc-44w9
References
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2024-56332 · CVE Program
- CVE-2024-56332 · NVD
- FIRST EPSS
- GHSA-7m27-7ghc-44w9 · GitHub Advisory Database · CC BY 4.0
- CVE-2024-56332 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences