Read the docs
TI-2024-37342 Aliases CVE-2024-56412GHSA-q9jv-mm3r-j47r

PhpSpreadsheet vulnerable to bypass of the XSS sanitizer using the javascript protocol and special characters

Priority MEDIUM 55CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Active
Attack complexity
Low
Attack requirements
None
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Versions prior to 3.7.0, 2.3.5, 2.1.6, and 1.29.7 are vulnerable to bypass of the cross-site scripting sanitizer using the javascript protocol and special characters. An attacker can use special characters, so that the library processes the javascript protocol with special characters and generates an HTML link. Versions 3.7.0, 2.3.5, 2.1.6, and 1.29.7 contain a patch for the issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0039 33rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PhpSpreadsheet (PHPOffice): 3.7.0, 1.29.7, 2.1.6 +1phpoffice/phpspreadsheet (Packagist): 3.7.0, 1.29.7, 2.1.6 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
PHPOfficePhpSpreadsheet3.0.0 to before 3.7.0; before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.53.7.0, 1.29.7, 2.1.6, 2.3.5Patch availableCNA
—phpoffice/phpspreadsheet (Packagist)3.0.0 to before 3.7.03.7.0Patch availableGHSA-q9jv-mm3r-j47r
—phpoffice/phpspreadsheet (Packagist)before 1.29.71.29.7Patch availableGHSA-q9jv-mm3r-j47r
—phpoffice/phpspreadsheet (Packagist)2.0.0 to before 2.1.62.1.6Patch availableGHSA-q9jv-mm3r-j47r
—phpoffice/phpspreadsheet (Packagist)2.2.0 to before 2.3.52.3.5Patch availableGHSA-q9jv-mm3r-j47r
—phpoffice/phpexcel (Packagist)up to 1.8.2—No fix listedGHSA-q9jv-mm3r-j47r
  • PhpSpreadsheet VendorPHPOffice Affected 3.0.0 to before 3.7.0; before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5 Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5 Patch available CNA
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.0.0 to before 3.7.0 Fixed in 3.7.0 Patch available GHSA-q9jv-mm3r-j47r
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.7 Fixed in 1.29.7 Patch available GHSA-q9jv-mm3r-j47r
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.6 Fixed in 2.1.6 Patch available GHSA-q9jv-mm3r-j47r
  • phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.3.5 Fixed in 2.3.5 Patch available GHSA-q9jv-mm3r-j47r
  • phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-q9jv-mm3r-j47r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:*before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5; 3.0.0 to before 3.7.0VulnerablePHPOffice
  • cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.29.7; 2.0.0 to before 2.1.6; 2.2.0 to before 2.3.5; 3.0.0 to before 3.7.0 Vulnerable ·PHPOffice

Remediation

  • Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 3.7.0, 1.29.7, 2.1.6, 2.3.5
  • Fix · GHSA-q9jv-mm3r-j47r phpoffice/phpspreadsheet (Packagist) Fixed in 3.7.0 Advisory →
  • Fix · GHSA-q9jv-mm3r-j47r phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.7 Advisory →
  • Fix · GHSA-q9jv-mm3r-j47r phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.6 Advisory →
  • Fix · GHSA-q9jv-mm3r-j47r phpoffice/phpspreadsheet (Packagist) Fixed in 2.3.5 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2024-56412
  2. 2026-10-03 Alias added: GHSA-q9jv-mm3r-j47r

References

  • TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
  • TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
  • TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
  • TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
  • TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
  • TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
See all 24 →

Sources