Cardealer <= 1.6.4 - Missing Authorization to Authenticated (Subscriber+) Change and Delete JS and CSS Files
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Cardealer theme for WordPress is vulnerable to unauthorized modification of data and loss of data due to a missing capability check and missing filename sanitization on the demo theme scheme AJAX functions in versions up to, and including, 1.6.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to change or delete arbitrary css and js files.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| ThemeMakers | Car Dealer Automotive WordPress Theme – Responsive | up to 1.6.4 | — | No fix listed | CNA |
- Car Dealer Automotive WordPress Theme – Responsive VendorThemeMakers Affected up to 1.6.4 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1681
- 2026-10-03 Alias added: GHSA-cx33-wwv9-rm3j
References
More ThemeMakers vulnerabilities
- TI-2025-26222 WordPress Car Dealer theme < 1.6.8 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-33266 WordPress ThemeMakers Visual Content Composer Plugin <= 1.5.8 - PHP Object Injection Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2025-01096 Path traversal in ThemeMakers Car Dealer Automotive WordPress Theme – Responsive CVSS 3.1HIGH 8.8
- TI-2025-01447 Cardealer <= 1.6.4 - Arbitrary Theme Option Update to Authenticated (Subscriber+) Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2025-01450 Cardealer <= 1.6.4 - Cross-Site Request Forgery to User Update via update_user_profile CVSS 3.1HIGH 8.8
- TI-2026-19664 WordPress Car Dealer theme <= 1.6.7 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2025-1681 · CVE Program
- CVE-2025-1681 · NVD
- FIRST EPSS
- GHSA-cx33-wwv9-rm3j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences