Cross-site scripting in OpenCart
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Cross-Site Scripting vulnerability in OpenCart versions prior to 4.1.0. This vulnerability allows an attacker to execute JavaScript code in the victim's browser by sending the victim a malicious URL using the search in the /product/search endpoint. This vulnerability could be exploited to steal sensitive user data, such as session cookies, or to perform actions on behalf of the user.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
- Fix · CNA OpenCart (OpenCart) Fixed in 4.1.0
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
OpenCart 4.1.0
4 records Highest priority Priority LOW 4 LOW
Other records, highest priority first
- TI-2025-01506 HTML injection vulnerability in OpenCartPriority LOW 21
- TI-2025-01505 HTML injection vulnerability in OpenCartPriority LOW 21
- TI-2025-01504 HTML injection vulnerability in OpenCartPriority LOW 21
Timeline
- 2026-10-02 Threatist record created from CVE-2025-1746
- 2026-10-03 Alias added: GHSA-52xm-jh2q-v993
References
More Opencart vulnerabilities
- TI-2023-21572 OpenCart CMS v4.0.2.2 was discovered to lack a protective mechanism on its login page… CVSS 3.1CRITICAL 9.8
- TI-2024-38428 OpenCart Core 4.0.2.3 SQL Injection via search Parameter CVSS 4.0HIGH 8.8
- TI-2023-25651 An issue discovered in OpenCart 4.0.0.0 to 4.0.2.3 allows authenticated backend users… CVSS 3.1HIGH 8.8
- TI-2023-02171 Improper input validation in Opencart CVSS 3.1HIGH 8.8
- TI-2024-14270 SQL injection in opencart/opencart CVSS 3.1HIGH 8.1
- TI-2024-24380 OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function. CVSS 3.1HIGH 7.2
Sources
- CVE-2025-1746 · CVE Program
- CVE-2025-1746 · NVD
- FIRST EPSS
- GHSA-52xm-jh2q-v993 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences