Read the docs
TI-2025-01504 Aliases CVE-2025-1747GHSA-mg9h-3wx4-hhfr

HTML injection vulnerability in OpenCart

Priority LOW 21CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

HTML injection vulnerabilities in OpenCart versions prior to 4.1.0. These vulnerabilities could allow an attacker to modify the HTML of the victim's browser by sending a malicious URL and modifying the parameter name in /account/login.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00257 17th percentileScored 2026-11-07
Fix Fixed OpenCart (OpenCart): 4.1.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
OpenCartOpenCartbefore 4.1.04.1.0Patch availableCNA
  • OpenCart VendorOpenCart Affected before 4.1.0 Fixed in 4.1.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:opencart:opencart:*:*:*:*:*:*:*:*before 4.1.0.0VulnerableOpenCart
  • cpe:2.3:a:opencart:opencart:*:*:*:*:*:*:*:* Versions before 4.1.0.0 Vulnerable ·OpenCart

Remediation

  • Fix · CNA OpenCart (OpenCart) Fixed in 4.1.0

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    OpenCart 4.1.0

    4 records Highest priority Priority LOW 4 LOW

    Other records, highest priority first

    • TI-2025-01503 Cross-site scripting in OpenCartPriority LOW 27
    • TI-2025-01506 HTML injection vulnerability in OpenCartPriority LOW 21
    • TI-2025-01505 HTML injection vulnerability in OpenCartPriority LOW 21

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-1747
  2. 2026-10-03 Alias added: GHSA-mg9h-3wx4-hhfr

References

  • TI-2023-21572 OpenCart CMS v4.0.2.2 was discovered to lack a protective mechanism on its login page… CVSS 3.1CRITICAL 9.8
  • TI-2024-38428 OpenCart Core 4.0.2.3 SQL Injection via search Parameter CVSS 4.0HIGH 8.8
  • TI-2023-25651 An issue discovered in OpenCart 4.0.0.0 to 4.0.2.3 allows authenticated backend users… CVSS 3.1HIGH 8.8
  • TI-2023-02171 Improper input validation in Opencart CVSS 3.1HIGH 8.8
  • TI-2024-14270 SQL injection in opencart/opencart CVSS 3.1HIGH 8.1
  • TI-2024-24380 OpenCart 4.0.2.3 is vulnerable to Server-Side Template Injection (SSTI) via the Theme Editor Function. CVSS 3.1HIGH 7.2
See all 38 →

Sources