Checkout Mestres do WP for WooCommerce 8.6.5 - 8.7.5 - Unauthenticated Arbitrary Options Update
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-862.
Summary
The Checkout Mestres do WP for WooCommerce plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the cwmpUpdateOptions() function in versions 8.6.5 to 8.7.5. This makes it possible for unauthenticated attackers to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mestres do WP | Checkout Mestres do WP for WooCommerce | 8.6.5 – 8.7.5 | — | No fix listed | CNA |
- Checkout Mestres do WP for WooCommerce VendorMestres do WP Affected 8.6.5 – 8.7.5 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-2266
- 2026-10-03 Alias added: GHSA-rw7q-vw4w-74r4
References
More Mestres do WP vulnerabilities
- TI-2025-23760 WordPress Checkout Mestres WP plugin <= 8.7.5 - Privilege Escalation Vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-28124 WordPress Checkout Mestres WP plugin <= 7.1.9.7 - Unauthenticated Account Takeover vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-28121 WordPress Checkout Mestres WP Plugin <= 7.1.9.6 is vulnerable to SQL Injection CVSS 3.1CRITICAL 9.8
- TI-2023-28123 WordPress Checkout Mestres WP plugin <= 7.1.9.7 - Unauthenticated Arbitrary Options Update vulnerability CVSS 3.1HIGH 8.2
- TI-2024-29619 WordPress Checkout Mestres WP plugin <= 8.6 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.2
Sources
- CVE-2025-2266 · CVE Program
- CVE-2025-2266 · NVD
- FIRST EPSS
- GHSA-rw7q-vw4w-74r4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences