Elementor <= 3.30.2 - Authenticated (Contributor+) Stored Cross-Site Scripting via Text Path Widget
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Elementor Website Builder – More Than Just a Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the data-text DOM element attribute in Text Path widget in all versions up to, and including, 3.30.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This attack affects only Chrome/Edge browsers
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4566
- 2026-10-03 Alias added: GHSA-pxcf-jw5h-2q73
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/af29ec92-5b07-4f57-a25f-19f3a894a193?source=cve
- https://plugins.trac.wordpress.org/browser/elementor/tags/3.28.4/assets/js/text-path.acb8842ac7e1cd1dfb44.bundle.js#L190
- https://plugins.trac.wordpress.org/browser/elementor/tags/3.28.4/assets/js/text-path.acb8842ac7e1cd1dfb44.bundle.js#L147
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3332337%40elementor&new=3332337%40elementor&sfp_email=&sfph_mail=
More Elementor vulnerabilities
- TI-2022-01211 Elementor Website Builder 3.6.0 - 3.6.2 - Missing Authorization to Remote Code Execution CVSS 3.1HIGH 8.8
- TI-2023-00313 Elementor Website Builder < 3.12.2 - Admin+ SQLi CVSS 3.1HIGH 7.2
- TI-2026-06653 Temporary Login <= 1.0.0 - Authentication Bypass to Account Takeover CVSS 3.1CRITICAL 9.8
- TI-2023-02927 Elementor Pro <= 3.11.6 - Authenticated(Subscriber+) Privilege Escalation via update_page_option CVSS 3.1HIGH 8.8
- TI-2020-10317 An issue was discovered in the Elementor Pro plugin before 2.9.4 for WordPress, as… CVSS 3.1CRITICAL 9.9
- TI-2023-25675 WordPress Elementor plugin <= 3.16.4 - Auth. Arbitrary Attachment Read vulnerability CVSS 3.1CRITICAL 9.8
Sources
- CVE-2025-4566 · CVE Program
- CVE-2025-4566 · NVD
- FIRST EPSS
- GHSA-pxcf-jw5h-2q73 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences