WP Extended <= 3.0.15 - Authenticated (Author+) Stored Cross-Site Scripting via SVG File Upload
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Extended plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG File uploads in all versions up to, and including, 3.0.15 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpextended | The Ultimate WordPress Toolkit – WP Extended | up to 3.0.15 | — | No fix listed | CNA |
- The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 3.0.15 Fixed in — No fix listed CNA
CPE names Threatist (inferred) · 1
Inferred from how NVD named this product before; not given by a source.
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:*:*:* | — | — | wpextended |
- cpe:2.3:a:wpextended:wp_extended:*:*:*:*:*:*:*:* Versions — — ·wpextended
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-4963
- 2026-10-03 Alias added: GHSA-xvgv-52hj-cf76
References
More wpextended vulnerabilities
- TI-2024-07515 Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-10960 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-03755 Improper privilege management in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-12230 The Ultimate WordPress Toolkit – WP Extended <= 3.0.12 - Unauthenticated SQL Injection via Login Attempts Module CVSS 3.1HIGH 7.5
- TI-2024-24774 WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2025-4963 · CVE Program
- CVE-2025-4963 · NVD
- FIRST EPSS
- GHSA-xvgv-52hj-cf76 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences