Read the docs
TI-2025-06690 Aliases CVE-2025-7338GHSA-fjgf-rc76-4x9p

Multer vulnerable to Denial of Service via unhandled exception from malformed request

Priority MEDIUM 40CWE-248Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Denial of service
Confidentiality · integrity · availability
None · None · High
Fix status
Partial Red Hat: 2 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-248.

Summary

Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00808 57th percentileScored 2026-11-07
Fix Partial multer (expressjs): 2.0.2multer (npm): 2.0.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
expressjsmulter1.4.4-lts.1 to before 2.0.22.0.2Patch availableCNA
—multer (npm)1.4.4-lts.1 to before 2.0.22.0.2Patch availableGHSA-fjgf-rc76-4x9p
  • multer Vendorexpressjs Affected 1.4.4-lts.1 to before 2.0.2 Fixed in 2.0.2 Patch available CNA
  • multer (npm) Vendor— Affected 1.4.4-lts.1 to before 2.0.2 Fixed in 2.0.2 Patch available GHSA-fjgf-rc76-4x9p

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:expressjs:multer:*:*:*:*:*:*:*:*——expressjs
  • cpe:2.3:a:expressjs:multer:*:*:*:*:*:*:*:* Versions — — ·expressjs

Remediation

  • Fix · CNA multer (expressjs) Fixed in 2.0.2
  • Fix · GHSA-fjgf-rc76-4x9p multer (npm) Fixed in 2.0.2 Advisory →

Red Hat 2 advisories

  • RHSA-2025:14767 Released 2025-08-27 · Red Hat rating Important
    Red Hat Developer Hub 1.6.4 release.
    • Red Hat Developer Hub 1.6 registry.redhat.io/rhdh/rhdh-hub-rhel9
  • RHSA-2025:14090 Released 2025-08-19 · Red Hat rating Important
    Red Hat Developer Hub 1.7.0 release.
    • Red Hat Developer Hub 1.7 registry.redhat.io/rhdh/rhdh-hub-rhel9, registry.redhat.io/rhdh/rhdh-rhel9-operator

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
OpenShift ServerlessAffectedNo fix planned: Will not fix
Red Hat Developer Hub 1.6Fixed RHSA-2025:14767
Red Hat Developer Hub 1.7Fixed RHSA-2025:14090
Not affected: 3 products
  • Red Hat Developer Hub 1
  • Red Hat Developer Hub 1.6
  • Red Hat Developer Hub 1.7

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-7338
  2. 2026-10-03 Alias added: GHSA-fjgf-rc76-4x9p
  3. 2026-10-27 Affected versions changed · Red Hat

References

  • TI-2024-08602 Open redirect in expressjs express CVSS 3.1MEDIUM 4.7
  • TI-2026-03033 Multer vulnerable to Denial of Service via uncontrolled recursion CVSS 4.0HIGH 8.7
  • TI-2026-02853 Multer vulnerable to Denial of Service via incomplete cleanup CVSS 4.0HIGH 8.7
  • TI-2026-01995 Multer vulnerable to Denial of Service via resource exhaustion CVSS 4.0HIGH 8.7
  • TI-2025-31125 Multer vulnerable to Denial of Service via unhandled exception CVSS 4.0HIGH 8.7
  • TI-2025-30337 Multer vulnerable to Denial of Service from maliciously crafted requests CVSS 3.1HIGH 7.5
See all 21 →

Sources