Read the docs
TI-2025-07877 Aliases CVE-2025-8606GHSA-7h92-gq8q-gpxg

GSheetConnector For Gravity Forms <= 1.3.23 - Cross-Site Request Forgery to Arbitrary Plugin Activation/Deactivation

Priority LOW 11CWE-352Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Tampering
Confidentiality · integrity · availability
None · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-352.

Summary

The GSheetConnector For Gravity Forms plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions less than, or equal to, 1.3.23. This is due to missing or incorrect nonce validation on the activate_plugin and deactivate_plugin functions. This makes it possible for attackers to trick authenticated administrators into activating or deactivating specified plugins via a forged request, such as clicking on a malicious link or visiting a compromised page.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00155 4th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
WesternDealGSheetConnector for Gravity Forms – Send Gravity Forms Entries to Google Sheets in Real-Timeup to 1.3.23—No fix listedCNA
  • GSheetConnector for Gravity Forms – Send Gravity Forms Entries to Google Sheets in Real-Time VendorWesternDeal Affected up to 1.3.23 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-8606
  2. 2026-10-03 Alias added: GHSA-7h92-gq8q-gpxg

References

  • TI-2023-02190 Easy Digital Downloads Google Sheet Connector < 1.6.6 - Access Code Update via CSRF CVSS 3.1MEDIUM 5.4
  • TI-2025-41588 WordPress WPForms Google Sheet Connector plugin <= 4.0.1 - Remote Code Execution (RCE) vulnerability CVSS 3.1CRITICAL 9.9
  • TI-2013-05910 Directory traversal vulnerability in download-file.php in the Advanced Dewplayer plugin… CVSS 2.0MEDIUM 5.0
  • TI-2025-07870 Missing authorization in WesternDeal GSheetConnector for Gravity Forms – Send Gravity… CVSS 3.1HIGH 8.8
  • TI-2024-05250 CF7 Google Sheets Connector <= 5.0.9 - Missing Authorization to Limited Site Configuration Update CVSS 3.1MEDIUM 6.5
  • TI-2025-16634 WordPress GSheetConnector for Forminator Forms Plugin <= 1.0.12 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
See all 13 →

Sources