Themify Builder <= 7.6.9 - Authenticated (Contributor+) Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Themify Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several parameters in all versions up to, and including, 7.6.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 7.6.9.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9353
- 2026-10-03 Alias added: GHSA-43wv-69rq-rx33
References
Other 7
- https://www.wordfence.com/threat-intel/vulnerabilities/id/508e97a0-9757-426c-bf0f-cdce6b489ce7?source=cve
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-icon.php#L95
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L73
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/templates/template-fancy-heading.php#L96
- https://plugins.trac.wordpress.org/browser/themify-builder/trunk/js/editor/build/modules.min.js
- https://plugins.trac.wordpress.org/changeset/3366817/
- https://plugins.trac.wordpress.org/changeset/3355757/
More themifyme vulnerabilities
- TI-2023-24789 WordPress Themify Ultra theme <= 7.3.5 - Authenticated Arbitrary Settings Change vulnerability CVSS 3.1HIGH 8.8
- TI-2024-02839 Themify Builder < 7.5.8 - Open Redirect CVSS 3.1MEDIUM 6.1
- TI-2023-02482 Conditional Menus < 1.2.1 - Reflected XSS CVSS 3.1MEDIUM 6.1
- TI-2023-00346 Themify Portfolio Post < 1.2.2 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2022-04383 Themify Shortcodes < 2.0.8 - Contributor+ Stored XSS via Shortcode CVSS 3.1MEDIUM 5.4
- TI-2022-04079 Themify Portfolio Post < 1.2.1 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-9353 · CVE Program
- CVE-2025-9353 · NVD
- FIRST EPSS
- GHSA-43wv-69rq-rx33 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences