Cross-Origin Opener Policy Vulnerability in pgAdmin 4
Priority LOW 36CWE-346Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-346.
Summary
pgAdmin <= 9.7 is affected by a Cross-Origin Opener Policy (COOP) vulnerability. This vulnerability allows an attacker to manipulate the OAuth flow, potentially leading to unauthorised account access, account takeover, data breaches, and privilege escalation.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00227 13th percentileScored 2026-11-07
Fix Fixed pgAdmin 4 (pgadmin.org): 9.8pgadmin4 (PyPI): 9.8
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | before 9.8 | 9.8 | Patch available | CNA |
| — | pgadmin4 (PyPI) | before 9.8 | 9.8 | Patch available | GHSA-6859-2qxq-ffv2 |
- pgAdmin 4 Vendorpgadmin.org Affected before 9.8 Fixed in 9.8 Patch available CNA
- pgadmin4 (PyPI) Vendor— Affected before 9.8 Fixed in 9.8 Patch available GHSA-6859-2qxq-ffv2
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | up to 9.7 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions up to 9.7 Vulnerable ·pgadmin.org
Remediation
- Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 9.8
- Fix · GHSA-6859-2qxq-ffv2 pgadmin4 (PyPI) Fixed in 9.8 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9636
- 2026-10-03 Alias added: GHSA-6859-2qxq-ffv2
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-9636 · CVE Program
- CVE-2025-9636 · NVD
- FIRST EPSS
- GHSA-6859-2qxq-ffv2 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-9636 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences