Secret data extraction via elfinder
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
SummaryA user with administrator rights can change the configuration of the mautic application and extract secrets that are not normally available. ImpactAn administrator who usually does not have access to certain parameters, such as database credentials, can disclose them.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Mautic | Mautic | >= 4.4.0 to before < 4.4.17; >= 5.0.0-alpha to before < 5.2.8; >= 6.0.0-alpha to before < 6.0.5 | < 4.4.17, < 5.2.8, < 6.0.5 | Patch available | CNA |
| — | mautic/core (Packagist) | 4.4.0 to before 4.4.17 | 4.4.17 | Patch available | GHSA-438m-6mhw-hq5w |
| — | mautic/core (Packagist) | 5.0.0-alpha to before 5.2.8 | 5.2.8 | Patch available | GHSA-438m-6mhw-hq5w |
| — | mautic/core (Packagist) | 6.0.0-alpha to before 6.0.5 | 6.0.5 | Patch available | GHSA-438m-6mhw-hq5w |
- Mautic VendorMautic Affected >= 4.4.0 to before < 4.4.17; >= 5.0.0-alpha to before < 5.2.8; >= 6.0.0-alpha to before < 6.0.5 Fixed in < 4.4.17, < 5.2.8, < 6.0.5 Patch available CNA
- mautic/core (Packagist) Vendor— Affected 4.4.0 to before 4.4.17 Fixed in 4.4.17 Patch available GHSA-438m-6mhw-hq5w
- mautic/core (Packagist) Vendor— Affected 5.0.0-alpha to before 5.2.8 Fixed in 5.2.8 Patch available GHSA-438m-6mhw-hq5w
- mautic/core (Packagist) Vendor— Affected 6.0.0-alpha to before 6.0.5 Fixed in 6.0.5 Patch available GHSA-438m-6mhw-hq5w
Remediation
- Fix · CNA Mautic (Mautic) Fixed in < 4.4.17, < 5.2.8, < 6.0.5
- Fix · GHSA-438m-6mhw-hq5w mautic/core (Packagist) Fixed in 4.4.17 Advisory →
- Fix · GHSA-438m-6mhw-hq5w mautic/core (Packagist) Fixed in 5.2.8 Advisory →
- Fix · GHSA-438m-6mhw-hq5w mautic/core (Packagist) Fixed in 6.0.5 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Mautic < 4.4.17, < 5.2.8, < 6.0.5
3 records Highest priority Priority LOW 3 LOW
Other records, highest priority first
- TI-2025-09012 User Enumeration via Response TimingPriority LOW 26
- TI-2025-09011 Reflected XSS in lead:addLeadTags - Quick AddPriority LOW 22
Timeline
- 2026-10-02 Threatist record created from CVE-2025-9822
- 2026-10-03 Alias added: GHSA-438m-6mhw-hq5w
References
More Mautic vulnerabilities
- TI-2022-09344 Cross-site scripting in Mautic CVSS 3.1CRITICAL 9.6
- TI-2024-02543 Predictable Page Indexing Might Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.3
- TI-2024-02544 Improper Access Control Issues Lead to Sensitive Data Exposure in Mautic CVSS 3.1MEDIUM 5.4
- TI-2024-03218 Improper Access Control Leads to Server-Side Request Forgery in Mautic CVSS 3.1MEDIUM 5.0
- TI-2024-31435 Remote Code Execution & File Deletion in Asset Uploads CVSS 3.1CRITICAL 9.9
- TI-2018-05847 Mautic before 2.13.0 allows CSV injection. CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-9822 · CVE Program
- CVE-2025-9822 · NVD
- FIRST EPSS
- GHSA-438m-6mhw-hq5w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences