Command injection vulnerability allowing arbitrary command execution on Windows
Priority MEDIUM 42CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
pgAdmin 4 versions up to 9.9 are affected by a command injection vulnerability on Windows systems. This issue is caused by the use of shell=True during backup and restore operations, enabling attackers to execute arbitrary system commands by providing specially crafted file path input.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00914 60th percentileScored 2026-11-07
Fix Fixed pgadmin4 (PyPI): 9.10
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | up to 9.9 | — | No fix listed | CNA |
| — | pgadmin4 (PyPI) | before 9.10 | 9.10 | Patch available | GHSA-rm79-x4g6-hvg5 |
- pgAdmin 4 Vendorpgadmin.org Affected up to 9.9 Fixed in — No fix listed CNA
- pgadmin4 (PyPI) Vendor— Affected before 9.10 Fixed in 9.10 Patch available GHSA-rm79-x4g6-hvg5
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | before 9.10 | Vulnerable | pgadmin.org |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions before 9.10 Vulnerable ·pgadmin.org
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · GHSA-rm79-x4g6-hvg5 pgadmin4 (PyPI) Fixed in 9.10 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-12763
- 2026-10-03 Alias added: GHSA-rm79-x4g6-hvg5
References
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-12763 · CVE Program
- CVE-2025-12763 · NVD
- FIRST EPSS
- GHSA-rm79-x4g6-hvg5 · GitHub Advisory Database · CC BY 4.0
- CVE-2025-12763 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences