Read the docs
TI-2025-11699 Aliases CVE-2025-12765GHSA-g4r8-3qmh-pmch

pgAdmin 4: LDAP authentication flow vulnerable to TLS certificate verification bypass.

Priority LOW 38CWE-295Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Spoofing
Confidentiality · integrity · availability
High · None · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-295.

Summary

pgAdmin <= 9.9  is affected by a vulnerability in the LDAP authentication mechanism allows bypassing TLS certificate verification.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0023 13th percentileScored 2026-11-07
Fix Fixed pgAdmin 4 (pgadmin.org): 9.10pgadmin4 (PyPI): 9.10

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
pgadmin.orgpgAdmin 4before 9.109.10Patch availableCNA
—pgadmin4 (PyPI)before 9.109.10Patch availableGHSA-g4r8-3qmh-pmch
  • pgAdmin 4 Vendorpgadmin.org Affected before 9.10 Fixed in 9.10 Patch available CNA
  • pgadmin4 (PyPI) Vendor— Affected before 9.10 Fixed in 9.10 Patch available GHSA-g4r8-3qmh-pmch

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:*before 9.10Vulnerablepgadmin.org
  • cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions before 9.10 Vulnerable ·pgadmin.org

Remediation

  • Fix · CNA pgAdmin 4 (pgadmin.org) Fixed in 9.10
  • Fix · GHSA-g4r8-3qmh-pmch pgadmin4 (PyPI) Fixed in 9.10 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    pgadmin.org pgAdmin 4 9.10

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

    • TI-2025-11698 pgAdmin 4: LDAP injection vulnerability in LDAP authentication flow.Priority LOW 39

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-12765
  2. 2026-10-03 Alias added: GHSA-g4r8-3qmh-pmch

References

  • TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
  • TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
  • TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
  • TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
  • TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
  • TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
See all 56 →

Sources