Remote Code Execution vulnerability when restoring PLAIN-format SQL dumps in server mode (pgAdmin 4)
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-94.
Summary
pgAdmin versions up to 9.10 are affected by a Remote Code Execution (RCE) vulnerability that occurs when running in server mode and performing restores from PLAIN-format dump files. This issue allows attackers to inject and execute arbitrary commands on the server hosting pgAdmin, posing a critical risk to the integrity and security of the database management system and underlying data.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| pgadmin.org | pgAdmin 4 | up to 9.10 | — | No fix listed | CNA |
| — | pgadmin4 (PyPI) | before 9.11 | 9.11 | Patch available | GHSA-fxmw-jcgr-w44v |
- pgAdmin 4 Vendorpgadmin.org Affected up to 9.10 Fixed in — No fix listed CNA
- pgadmin4 (PyPI) Vendor— Affected before 9.11 Fixed in 9.11 Patch available GHSA-fxmw-jcgr-w44v
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* | up to 9.10 | Vulnerable | pgadmin.org |
- cpe:2.3:a:pgadmin:pgadmin_4:*:*:*:*:*:postgresql:*:* Versions up to 9.10 Vulnerable ·pgadmin.org
Remediation
- Fix · GHSA-fxmw-jcgr-w44v pgadmin4 (PyPI) Fixed in 9.11 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2025-13780
- 2026-10-03 Alias added: GHSA-fxmw-jcgr-w44v
References
Other 5
- https://github.com/pgadmin-org/pgadmin4/issues/9368
- https://github.com/pgadmin-org/pgadmin4/pull/9426
- https://github.com/pgadmin-org/pgadmin4/commit/1d397395f75320ca1d4ed5e9ca721c603415e836
- https://github.com/pgadmin-org/pgadmin4/commit/d5a909f14cb9713d89b49481ad1929fad89f4576
- https://github.com/pgadmin-org/pgadmin4
More pgadmin.org Pgadmin 4 vulnerabilities
- TI-2024-01901 Unsafe Deserialisation and Remote Code Execution by an Authenticated user in pgAdmin 4 CVSS 3.1CRITICAL 9.9
- TI-2024-02918 Remote Code Execution Vulnerability through the validate binary path API in pgAdmin 4 CVSS 3.1CRITICAL 9.8
- TI-2022-03867 Code injection in pgadmin4 CVSS 3.1HIGH 8.8
- TI-2026-06875 pgAdmin 4: Cross-user data access and shared-server privilege escalation in server mode CVSS 4.0CRITICAL 9.4
- TI-2025-02572 pgAdmin 4: Remote Code Execution in Query Tool and Cloud Deployment CVSS 3.1CRITICAL 9.9
- TI-2023-00228 Path traversal in pgadmin CVSS 3.1MEDIUM 6.5
Sources
- CVE-2025-13780 · CVE Program
- CVE-2025-13780 · NVD
- FIRST EPSS
- GHSA-fxmw-jcgr-w44v · GitHub Advisory Database · CC BY 4.0
- CVE-2025-13780 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences