Custom Post Type UI <= 1.18.1 - Authenticated (Administrator+) Stored Cross-Site Scripting via 'label' Import Parameter
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
The Custom Post Type UI plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'label' parameter during custom post type import in all versions up to, and including, 1.18.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses the Tools → Get Code page.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| webdevstudios | Custom Post Type UI | up to 1.18.1 | — | No fix listed | CNA |
- Custom Post Type UI Vendorwebdevstudios Affected up to 1.18.1 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-14056
- 2026-10-03 Alias added: GHSA-gx74-2mp6-xwmq
References
Other 4
- https://www.wordfence.com/threat-intel/vulnerabilities/id/890c743e-da5e-46ed-a011-cecd24778163?source=cve
- https://plugins.trac.wordpress.org/browser/custom-post-type-ui/trunk/inc/tools-sections/tools-post-types.php#L201
- https://plugins.trac.wordpress.org/browser/custom-post-type-ui/tags/1.18.1/inc/tools-sections/tools-post-types.php#L201
- https://github.com/WebDevStudios/custom-post-type-ui/pull/1014/files#diff-bd3331205024f12a78d74b312bc4f5ad118b5734999bf53a4a95e0959891f60a
More webdevstudios vulnerabilities
- TI-2023-01527 Custom Post Type UI < 1.13.5 - Debug Info Sending via CSRF CVSS 3.1MEDIUM 6.5
- TI-2025-30471 WordPress Constant Contact for WordPress Plugin <= 4.1.1 - PHP Object Injection Vulnerability CVSS 3.1HIGH 8.8
- TI-2015-07750 PayPal Pro Add-on for iThemes Exchange before 1.1.0 for WordPress has XSS via add_query_arg() and remove_query_arg(). CVSS 3.0MEDIUM 6.1
- TI-2015-08048 WDS Multisite Aggregate Plugin WDS_Multisite_Aggregate_Options.php update_options cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2015-07941 WebDevStudios taxonomy-switcher Plugin taxonomy-switcher.php taxonomy_switcher_init cross site scripting CVSS 3.1MEDIUM 6.1
- TI-2025-11749 Missing authorization in webdevstudios Custom Post Type UI CVSS 3.1MEDIUM 4.8
Sources
- CVE-2025-14056 · CVE Program
- CVE-2025-14056 · NVD
- FIRST EPSS
- GHSA-gx74-2mp6-xwmq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences