Cross-Site Scripting (XSS) vulnerability in generateNavigation() function
Priority MEDIUM 56CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
PhpSpreadsheet is a PHP library for reading and writing spreadsheet files. Cross-Site Scripting (XSS) vulnerability in the code which translates the XLSX file into a HTML representation and displays it in the response.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00396 34th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed PhpSpreadsheet (PHPOffice): 3.8.0, 2.3.6, 2.1.7 +1phpoffice/phpspreadsheet (Packagist): 3.8.0, 1.29.8, 2.1.7 +1
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| PHPOffice | PhpSpreadsheet | 3.0.0 to before 3.8.0; 2.2.0 to before 2.3.6; 2.0.0 to before 2.1.7; before 1.29.8 | 3.8.0, 2.3.6, 2.1.7, 1.29.8 | Patch available | CNA |
| — | phpoffice/phpspreadsheet (Packagist) | 3.0.0 to before 3.8.0 | 3.8.0 | Patch available | GHSA-79xx-vf93-p7cx |
| — | phpoffice/phpspreadsheet (Packagist) | before 1.29.8 | 1.29.8 | Patch available | GHSA-79xx-vf93-p7cx |
| — | phpoffice/phpspreadsheet (Packagist) | 2.0.0 to before 2.1.7 | 2.1.7 | Patch available | GHSA-79xx-vf93-p7cx |
| — | phpoffice/phpspreadsheet (Packagist) | 2.2.0 to before 2.3.6 | 2.3.6 | Patch available | GHSA-79xx-vf93-p7cx |
| — | phpoffice/phpexcel (Packagist) | up to 1.8.2 | — | No fix listed | GHSA-79xx-vf93-p7cx |
- PhpSpreadsheet VendorPHPOffice Affected 3.0.0 to before 3.8.0; 2.2.0 to before 2.3.6; 2.0.0 to before 2.1.7; before 1.29.8 Fixed in 3.8.0, 2.3.6, 2.1.7, 1.29.8 Patch available CNA
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 3.0.0 to before 3.8.0 Fixed in 3.8.0 Patch available GHSA-79xx-vf93-p7cx
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected before 1.29.8 Fixed in 1.29.8 Patch available GHSA-79xx-vf93-p7cx
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.0.0 to before 2.1.7 Fixed in 2.1.7 Patch available GHSA-79xx-vf93-p7cx
- phpoffice/phpspreadsheet (Packagist) Vendor— Affected 2.2.0 to before 2.3.6 Fixed in 2.3.6 Patch available GHSA-79xx-vf93-p7cx
- phpoffice/phpexcel (Packagist) Vendor— Affected up to 1.8.2 Fixed in — No fix listed GHSA-79xx-vf93-p7cx
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* | before 1.29.8; 2.0.0 to before 2.1.7; 2.2.0 to before 2.3.6; 3.0.0 to before 3.8.0 | Vulnerable | PHPOffice |
- cpe:2.3:a:phpoffice:phpspreadsheet:*:*:*:*:*:*:*:* Versions before 1.29.8; 2.0.0 to before 2.1.7; 2.2.0 to before 2.3.6; 3.0.0 to before 3.8.0 Vulnerable ·PHPOffice
Remediation
- Fix · CNA PhpSpreadsheet (PHPOffice) Fixed in 3.8.0, 2.3.6, 2.1.7, 1.29.8
- Fix · GHSA-79xx-vf93-p7cx phpoffice/phpspreadsheet (Packagist) Fixed in 3.8.0 Advisory →
- Fix · GHSA-79xx-vf93-p7cx phpoffice/phpspreadsheet (Packagist) Fixed in 1.29.8 Advisory →
- Fix · GHSA-79xx-vf93-p7cx phpoffice/phpspreadsheet (Packagist) Fixed in 2.1.7 Advisory →
- Fix · GHSA-79xx-vf93-p7cx phpoffice/phpspreadsheet (Packagist) Fixed in 2.3.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-22131
- 2026-10-03 Alias added: GHSA-79xx-vf93-p7cx
References
More PHPOffice Phpspreadsheet vulnerabilities
- TI-2026-26406 PhpSpreadsheet SSRF and RCE via PHP stream wrappers in IOFactory::load CVSS 4.0CRITICAL 9.2
- TI-2024-37339 PhpSpreadsheet vulnerable to unauthorized reflected XSS in Currency.php file CVSS 4.0HIGH 8.3
- TI-2024-37338 PhpSpreadsheet allows unauthorized reflected XSS in `Convert-Online.php` file CVSS 4.0HIGH 8.3
- TI-2024-37325 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the Accounting.php file CVSS 4.0HIGH 8.3
- TI-2024-37324 PhpSpreadsheet vulnerable to unauthorized reflected XSS in the constructor of the Downloader class CVSS 4.0HIGH 8.3
- TI-2024-30160 XML External Entity Reference (XXE) in PHPSpreadsheet CVSS 3.1HIGH 8.8
Sources
- CVE-2025-22131 · CVE Program
- CVE-2025-22131 · NVD
- FIRST EPSS
- GHSA-79xx-vf93-p7cx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences