Read the docs
TI-2025-16706 Aliases CVE-2025-22825GHSA-pwq9-r746-qmmp

WordPress Flexible PDF Coupons plugin < 1.10.3 - Stored Cross Site Scripting (XSS) vulnerability

Priority LOW 28CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · Low
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in wpdesk Flexible PDF Coupons flexible-coupons allows Stored XSS.This issue affects Flexible PDF Coupons: from n/a through < 1.10.3.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00223 12th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
wpdeskFlexible PDF Couponsup to 1.10.3—No fix listedCNA
  • Flexible PDF Coupons Vendorwpdesk Affected up to 1.10.3 Fixed in — No fix listed CNA

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-22825
  2. 2026-10-03 Alias added: GHSA-pwq9-r746-qmmp

References

  • TI-2026-51484 WordPress Flexible Subscriptions plugin <= 1.8.1 - PHP Object Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2020-18902 Flexible Checkout Fields for WooCommerce <= 2.3.1 - Unauthenticated Arbitrary Plugin Settings Update CVSS 3.1HIGH 7.2
  • TI-2026-83314 Sensitive data exposure in WordPress Flexible Chat plugin CVSS 3.1HIGH 7.5
  • TI-2026-73809 Local file inclusion in ShopMagic plugin lets attackers run PHP files CVSS 3.1HIGH 8.1
  • TI-2024-20643 WordPress Flexible Checkout Fields for WooCommerce plugin <= 4.1.2 - Broken Access Control vulnerability CVSS 3.1HIGH 8.8
  • TI-2024-12735 Flexible Wishlist for WooCommerce <= 1.2.25 - Unauthenticated Stored Cross-Site Scripting via wishlist_name Parameter CVSS 3.1HIGH 7.2
See all 25 →

Sources