Read the docs
TI-2025-18247 Aliases CVE-2025-24530GHSA-222v-cx2c-q2f5

Cross-site scripting in phpMyAdmin

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00409 35th percentileScored 2026-11-07
Fix Fixed phpMyAdmin (phpMyAdmin): 5.2.2phpmyadmin/phpmyadmin (Packagist): 5.2.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
phpMyAdminphpMyAdmin5.0.0 to before 5.2.25.2.2Patch availableCNA
—phpmyadmin/phpmyadmin (Packagist)5.0.0 to before 5.2.25.2.2Patch availableGHSA-222v-cx2c-q2f5
  • phpMyAdmin VendorphpMyAdmin Affected 5.0.0 to before 5.2.2 Fixed in 5.2.2 Patch available CNA
  • phpmyadmin/phpmyadmin (Packagist) Vendor— Affected 5.0.0 to before 5.2.2 Fixed in 5.2.2 Patch available GHSA-222v-cx2c-q2f5

CPE names Threatist (inferred) · 1

Inferred from how NVD named this product before; not given by a source.

CPEVersionsRoleVendor
cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:*——phpMyAdmin
  • cpe:2.3:a:phpmyadmin:phpmyadmin:*:*:*:*:*:*:*:* Versions — — ·phpMyAdmin

Remediation

  • Fix · CNA phpMyAdmin (phpMyAdmin) Fixed in 5.2.2
  • Fix · GHSA-222v-cx2c-q2f5 phpmyadmin/phpmyadmin (Packagist) Fixed in 5.2.2 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    phpMyAdmin 5.2.2

    2 records Highest priority Priority LOW 2 LOW

    Other records, highest priority first

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-24530
  2. 2026-10-03 Alias added: GHSA-222v-cx2c-q2f5

References

  • TI-2009-01092 Static code injection vulnerability in setup.php in phpMyAdmin 2.11.x before 2.11.9.5 and… KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-09056 An issue was discovered in phpMyAdmin 4.8.x before 4.8.2, in which an attacker can… CVSS 3.1HIGH 8.8
  • TI-2020-14341 SQL Injection vulnerability in function getTableCreationQuery in CreateAddField.php in… CVSS 3.1CRITICAL 9.8
  • TI-2016-04978 phpMyAdmin 4.0.x before 4.0.10.16, 4.4.x before 4.4.15.7, and 4.6.x before 4.6.3 does not… CVSS 3.0CRITICAL 9.8
  • TI-2020-16362 An issue was discovered in SearchController in phpMyAdmin before 4.9.6 and 5.x before… CVSS 3.1CRITICAL 9.8
  • TI-2012-04350 phpMyAdmin 3.5.2.2, as distributed by the cdnetworks-kr-1 mirror during an unspecified… CVSS 2.0HIGH 7.5
See all 281 →

Sources