WordPress Music Store – WordPress eCommerce Plugin <= 1.1.19 - Reflected Cross Site Scripting (XSS) vulnerability
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in codepeople Music Store music-store allows Reflected XSS.This issue affects Music Store: from n/a through <= 1.1.19.
Why it matters now
Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00266 18th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| codepeople | Music Store | up to 1.1.19 | — | No fix listed | CNA |
- Music Store Vendorcodepeople Affected up to 1.1.19 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-24626
- 2026-10-03 Alias added: GHSA-8cgh-g4jm-qrhx
More codepeople vulnerabilities
- TI-2024-00790 Booking Calendar < 1.3.83 - CSRF appointment scheduling CVSS 3.1HIGH 8.8
- TI-2024-11385 BookingPress < 1.1.23 - Unauthenticated Export File Download CVSS 3.1HIGH 7.5
- TI-2024-03387 Smart Image Gallery < 1.0.19 - Update/Delete Google API Key via CSRF CVSS 3.1MEDIUM 6.8
- TI-2023-05486 Contact Form Email < 1.3.44 - Editor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2024-08220 Polls CP <= 1.0.75 - Admin+ Stored XSS via Custom Styles CVSS 3.1MEDIUM 5.4
- TI-2024-08217 Polls CP <= 1.0.75 - Admin+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2025-24626 · CVE Program
- CVE-2025-24626 · NVD
- FIRST EPSS
- GHSA-8cgh-g4jm-qrhx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences