Read the docs
TI-2025-19469 Aliases CVE-2025-26531GHSA-g88w-v4cq-qgcp

IDOR in badges allows disabling of arbitrary badges

Priority LOW 24CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Insufficient capability checks made it possible to disable badges a user does not have permission to access.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00301 22nd percentileScored 2026-11-07
Fix Fixed moodle (Moodle Project): 4.5.2, 4.4.6, 4.3.10 +1moodle/moodle (Packagist): 4.5.2, 4.4.6, 4.3.10 +1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
Moodlemoodle4.5.0 to before 4.5.2; 4.4.0 to before 4.4.6; 4.3.0 to before 4.3.10; 4.1.0 to before 4.1.164.5.2, 4.4.6, 4.3.10, 4.1.16Patch availableCNA
—moodle/moodle (Packagist)4.5.0-beta to before 4.5.24.5.2Patch availableGHSA-g88w-v4cq-qgcp
—moodle/moodle (Packagist)4.4.0-beta to before 4.4.64.4.6Patch availableGHSA-g88w-v4cq-qgcp
—moodle/moodle (Packagist)4.3.0-beta to before 4.3.104.3.10Patch availableGHSA-g88w-v4cq-qgcp
—moodle/moodle (Packagist)before 4.1.164.1.16Patch availableGHSA-g88w-v4cq-qgcp
  • moodle VendorMoodle Affected 4.5.0 to before 4.5.2; 4.4.0 to before 4.4.6; 4.3.0 to before 4.3.10; 4.1.0 to before 4.1.16 Fixed in 4.5.2, 4.4.6, 4.3.10, 4.1.16 Patch available CNA
  • moodle/moodle (Packagist) Vendor— Affected 4.5.0-beta to before 4.5.2 Fixed in 4.5.2 Patch available GHSA-g88w-v4cq-qgcp
  • moodle/moodle (Packagist) Vendor— Affected 4.4.0-beta to before 4.4.6 Fixed in 4.4.6 Patch available GHSA-g88w-v4cq-qgcp
  • moodle/moodle (Packagist) Vendor— Affected 4.3.0-beta to before 4.3.10 Fixed in 4.3.10 Patch available GHSA-g88w-v4cq-qgcp
  • moodle/moodle (Packagist) Vendor— Affected before 4.1.16 Fixed in 4.1.16 Patch available GHSA-g88w-v4cq-qgcp

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:*4.1.0 to before 4.1.16; 4.3.0 to before 4.3.10; 4.4.0 to before 4.4.6; 4.5.0 to before 4.5.2VulnerableMoodle
  • cpe:2.3:a:moodle:moodle:*:*:*:*:*:*:*:* Versions 4.1.0 to before 4.1.16; 4.3.0 to before 4.3.10; 4.4.0 to before 4.4.6; 4.5.0 to before 4.5.2 Vulnerable ·Moodle

Remediation

  • Fix · CNA moodle (Moodle Project) Fixed in 4.5.2, 4.4.6, 4.3.10, 4.1.16
  • Fix · GHSA-g88w-v4cq-qgcp moodle/moodle (Packagist) Fixed in 4.5.2 Advisory →
  • Fix · GHSA-g88w-v4cq-qgcp moodle/moodle (Packagist) Fixed in 4.4.6 Advisory →
  • Fix · GHSA-g88w-v4cq-qgcp moodle/moodle (Packagist) Fixed in 4.3.10 Advisory →
  • Fix · GHSA-g88w-v4cq-qgcp moodle/moodle (Packagist) Fixed in 4.1.16 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    moodle 4.0.*, 4.1.16 and 4 more versions

    8 records Highest priority Priority MEDIUM 2 MEDIUM, 6 LOW

    Other records, highest priority first

    • TI-2025-19471 SQL injection risk in course search module list filterPriority MEDIUM 44
    • TI-2025-19463 Arbitrary file read risk through pdfTeXPriority MEDIUM 44
    • TI-2025-19467 Stored XSS risk in admin live logPriority LOW 39

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-26531
  2. 2026-10-03 Alias added: GHSA-g88w-v4cq-qgcp

References

  • TI-2024-22468 moodle: unsafe direct use of $_SERVER['HTTP_REFERER'] in admin/tool/mfa/index.php CVSS 3.1CRITICAL 9.8
  • TI-2021-14741 In Moodle, an SQL injection risk was identified in the library fetching a user's recent courses. CVSS 3.1CRITICAL 9.8
  • TI-2024-29071 Moodle: remote code execution via calculated question types CVSS 3.1HIGH 8.1
  • TI-2016-06653 Moodle 3.1.2 allows remote attackers to obtain sensitive information via unspecified… CVSS 3.1HIGH 7.5
  • TI-2022-00259 SQL injection in moodle CVSS 3.1CRITICAL 9.8
  • TI-2022-16116 Path traversal in Moodle CVSS 3.1HIGH 7.5
See all 636 →

Sources