Metabase Enterprise Edition allows cached questions to leak data to impersonated users
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Active
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA.
Summary
Metabase Enterprise Edition is the enterprise version of Metabase business intelligence and data analytics software. Starting in version 1.47.0 and prior to versions 1.50.36, 1.51.14, 1.52.11, and 1.53.2 of Metabase Enterprise Edition, users with impersonation permissions may be able to see results of cached questions, even if their permissions don’t allow them to see the data. If some user runs a question which gets cached, and then an impersonated user runs that question, then the impersonated user sees the same results as the previous user. These cached results may include data the impersonated user should not have access to. This vulnerability only impacts the Enterprise Edition of Metabase and not the Open Source Edition. Versions 1.53.2, 1.52.11, 1.51.14, and 1.50.36 contains a patch. Versions on the 1.49.X, 1.48.X, and 1.47.X branches are vulnerable but do not have a patch available, so users should upgrade to a major version with an available fix. Disabling question caching is a workaround for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Metabase | metabase | 1.47.0 to before 1.50.36; 1.51.0 to before 1.51.14; 1.52.0 to before 1.51.11; 1.53.0 to before 1.53.2 | 1.50.36, 1.51.14, 1.51.11, 1.53.2 | Patch available | CNA |
- metabase VendorMetabase Affected 1.47.0 to before 1.50.36; 1.51.0 to before 1.51.14; 1.52.0 to before 1.51.11; 1.53.0 to before 1.53.2 Fixed in 1.50.36, 1.51.14, 1.51.11, 1.53.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* | 1.47.0 to before 1.50.36; 1.51.0 to before 1.51.14; 1.52.0 to before 1.52.11; 1.53.0 to before 1.53.2 | Vulnerable | Metabase |
- cpe:2.3:a:metabase:metabase:*:*:*:*:enterprise:*:*:* Versions 1.47.0 to before 1.50.36; 1.51.0 to before 1.51.14; 1.52.0 to before 1.52.11; 1.53.0 to before 1.53.2 Vulnerable ·Metabase
Remediation
- Fix · CNA metabase (metabase) Fixed in 1.50.36, 1.51.14, 1.51.11, 1.53.2
Timeline
- 2026-10-02 Threatist record created from CVE-2025-27141
References
More Metabase vulnerabilities
- TI-2026-51115 Metabase SQL injection via password reset endpoint KEVCVSS 4.0CRITICAL 10.0
- TI-2021-18109 GeoJSON URL validation can expose server files and environment variables to unauthorized users KEVCVSS 3.1CRITICAL 10.0
- TI-2023-20003 Metabase open source before 0.46.6.1 and Metabase Enterprise before 1.46.6.1 allow… CVSS 3.1CRITICAL 9.8
- TI-2022-08664 File system exposure in Metabase CVSS 3.1MEDIUM 5.9
- TI-2025-05321 Metabase dom.js parseDataUri redos CVSS 4.0MEDIUM 5.3
- TI-2023-19078 Metabase vulnerable to remote code execution via POST /api/setup/validate API endpoint CVSS 3.1CRITICAL 10.0
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences