Read the docs
TI-2025-20493 Aliases CVE-2025-27696GHSA-w6c7-j32f-rq8j

Apache Superset: Incorrect authorization leading to resource ownership takeover

Priority LOW 33CWE-863Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Security bypass
Confidentiality · integrity · availability
None · Low · None
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-863.

Summary

Incorrect Authorization vulnerability in Apache Superset allows ownership takeover of dashboards, charts or datasets by authenticated users with read permissions. This issue affects Apache Superset: through 4.1.1. Users are recommended to upgrade to version 4.1.2 or above, which fixes the issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.013 70th percentileScored 2026-11-07
Fix Fixed apache-superset (PyPI): 4.1.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache Supersetup to 4.1.1—No fix listedCNA
—apache-superset (PyPI)before 4.1.24.1.2Patch availableGHSA-w6c7-j32f-rq8j
  • Apache Superset VendorApache Affected up to 4.1.1 Fixed in — No fix listed CNA
  • apache-superset (PyPI) Vendor— Affected before 4.1.2 Fixed in 4.1.2 Patch available GHSA-w6c7-j32f-rq8j

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:*before 4.1.2VulnerableApache
  • cpe:2.3:a:apache:superset:*:*:*:*:*:*:*:* Versions before 4.1.2 Vulnerable ·Apache

Remediation

  • Fix · GHSA-w6c7-j32f-rq8j apache-superset (PyPI) Fixed in 4.1.2 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-27696
  2. 2026-10-03 Alias added: GHSA-w6c7-j32f-rq8j

References

  • TI-2023-12249 Apache Superset: Session validation vulnerability when using provided default SECRET_KEY KEVCVSS 3.1CRITICAL 9.8
  • TI-2018-05798 Deserialization of untrusted data in Superset CVSS 3.0CRITICAL 9.8
  • TI-2023-21408 Apache Superset: Privilege escalation with default examples database CVSS 3.1HIGH 8.8
  • TI-2023-20410 Apache Superset: Possible Unauthorized Registration of SQLite Database Connections CVSS 3.1MEDIUM 6.5
  • TI-2021-09242 Apache Superset stored XSS on Dashboard markdown CVSS 3.1MEDIUM 5.4
  • TI-2021-09359 Apache Superset Open Redirect CVSS 3.1MEDIUM 6.1
See all 69 →

Sources