WordPress The Ultimate WordPress Toolkit – WP Extended plugin <= 3.0.14 - Cross Site Scripting (XSS) vulnerability
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.
Summary
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in WP Extended The Ultimate WordPress Toolkit – WP Extended wpextended allows Reflected XSS.This issue affects The Ultimate WordPress Toolkit – WP Extended: from n/a through <= 3.0.14.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| wpextended | The Ultimate WordPress Toolkit – WP Extended | up to 3.0.14 | — | No fix listed | CNA |
- The Ultimate WordPress Toolkit – WP Extended Vendorwpextended Affected up to 3.0.14 Fixed in — No fix listed CNA
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2025-30796
- 2026-10-03 Alias added: GHSA-j9c8-34wr-822j
More wpextended vulnerabilities
- TI-2024-07515 Path traversal in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-10960 Missing authorization in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-07513 The Ultimate WordPress Toolkit – WP Extended <= 3.0.8 - Authenticated (Subscriber+) Arbitrary Options Update CVSS 3.1HIGH 8.8
- TI-2026-03755 Improper privilege management in wpextended The Ultimate WordPress Toolkit – WP Extended CVSS 3.1HIGH 8.8
- TI-2024-12230 The Ultimate WordPress Toolkit – WP Extended <= 3.0.12 - Unauthenticated SQL Injection via Login Attempts Module CVSS 3.1HIGH 7.5
- TI-2024-24774 WordPress WP Extended plugin <= 2.4.7 - Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
Sources
- CVE-2025-30796 · CVE Program
- CVE-2025-30796 · NVD
- FIRST EPSS
- GHSA-j9c8-34wr-822j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences