Read the docs
TI-2025-24410 Aliases CVE-2025-34267GHSA-r4hh-pcgx-j5r2

Flowise Authenticated Command Execution and Sandbox Bypass via Puppeteer & Playwright Packages

Priority HIGH 70CWE-77Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
None
Attack complexity
Low
Attack requirements
None
Impact type
Code execution
Confidentiality · integrity · availability
High · Low · Low
Fix status
Fixed

Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-77.

Summary

Flowise v3.0.1 < 3.0.8 and all versions after with 'ALLOW_BUILTIN_DEP' enabled contain an authenticated remote code execution vulnerability and node VM sandbox escape due to insecure use of integrated modules (Puppeteer and Playwright) within the nodevm execution environment. An authenticated attacker able to create or run a tool that leverages Puppeteer/Playwright can specify attacker-controlled browser binary paths and parameters. When the tool executes, the attacker-controlled executable/parameters are run on the host and circumvent the intended nodevm sandbox restrictions, resulting in execution of arbitrary code in the context of the host. This vulnerability was incorrectly assigned as a duplicate CVE-2025-26319 by the developers and should be considered distinct from that identifier.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.06885 94th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed flowise (npm): 3.0.8

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
FlowiseAIFlowise3.0.1 – 3.0.8—No fix listedCNA
—flowise (npm)3.0.1 to before 3.0.83.0.8Patch availableGHSA-r4hh-pcgx-j5r2
  • Flowise VendorFlowiseAI Affected 3.0.1 – 3.0.8 Fixed in — No fix listed CNA
  • flowise (npm) Vendor— Affected 3.0.1 to before 3.0.8 Fixed in 3.0.8 Patch available GHSA-r4hh-pcgx-j5r2

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:*3.0.1 to before 3.0.8VulnerableFlowiseAI
  • cpe:2.3:a:flowiseai:flowise:*:*:*:*:*:*:*:* Versions 3.0.1 to before 3.0.8 Vulnerable ·FlowiseAI

Remediation

  • Fix · GHSA-r4hh-pcgx-j5r2 flowise (npm) Fixed in 3.0.8 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2025-34267
  2. 2026-10-03 Alias added: GHSA-r4hh-pcgx-j5r2

References

  • TI-2025-37059 Flowise has Remote Code Execution vulnerability CVSS 3.1CRITICAL 10.0
  • TI-2025-36193 Flowise Cloud and Local Deployments have Unauthenticated Password Reset Token Disclosure that Leads to Account Takeover CVSS 3.1CRITICAL 9.8
  • TI-2025-08190 Unsupervised OS command execution leads to remote code execution by unauthenticated network attackers CVSS 3.1CRITICAL 9.8
  • TI-2026-51595 Flowise before 3.1.3 Sandbox Escape via Puppeteer CVSS 4.0CRITICAL 9.4
  • TI-2026-49250 Flowise: CSV Agent Prompt Injection Remote Code Execution Vulnerability CVSS 4.0CRITICAL 9.5
  • TI-2025-43459 Flowise through 2.2.7 - Arbitrary File Write to Remote Code Execution via document-store API CVSS 4.0CRITICAL 10.0
See all 127 →

Sources