passport-wsfed-saml2 Has SAML Authentication Bypass via Attribute Smuggling
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Attack requirements
- None
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 4.0 · CNA. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
passport-wsfed-saml2 provides passport strategy for both WS-fed and SAML2 protocol. A vulnerability present starting in version 3.0.5 up to and including version 4.6.3 allows an attacker to impersonate any user during SAML authentication by tampering with a valid SAML response. This can be done by adding attributes to the response. Users are affected specifically when the service provider is using `passport-wsfed-saml2` and a valid SAML Response signed by the Identity Provider can be obtained. Version 4.6.4 contains a fix for the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| auth0 | passport-wsfed-saml2 | 3.0.5 to before 4.6.4 | 4.6.4 | Patch available | CNA |
| — | passport-wsfed-saml2 (npm) | 3.0.5 to before 4.6.4 | 4.6.4 | Patch available | GHSA-8gqj-226h-gm8r |
- passport-wsfed-saml2 Vendorauth0 Affected 3.0.5 to before 4.6.4 Fixed in 4.6.4 Patch available CNA
- passport-wsfed-saml2 (npm) Vendor— Affected 3.0.5 to before 4.6.4 Fixed in 4.6.4 Patch available GHSA-8gqj-226h-gm8r
Remediation
- Fix · CNA passport-wsfed-saml2 (auth0) Fixed in 4.6.4
- Fix · GHSA-8gqj-226h-gm8r passport-wsfed-saml2 (npm) Fixed in 4.6.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2025-46573
- 2026-10-03 Alias added: GHSA-8gqj-226h-gm8r
References
More auth0 vulnerabilities
- TI-2015-07615 Improper input validation in HackerOne jsonwebtoken node module CVSS 3.0CRITICAL 9.8
- TI-2025-29805 Brute Force Authentication Tags of CookieStore Sessions in Auth0-PHP SDK CVSS 3.1CRITICAL 9.1
- TI-2025-31089 Auth0-PHP SDK Deserialization of Untrusted Data vulnerability CVSS 4.0CRITICAL 9.3
- TI-2020-06427 An issue was discovered in the Login by Auth0 plugin before 4.0.0 for WordPress. CVSS 3.1CRITICAL 9.8
- TI-2018-05020 The Auth0 authentication service before 2017-10-15 allows privilege escalation because… CVSS 3.0CRITICAL 9.8
- TI-2019-05387 Auth0 Auth0-WCF-Service-JWT before 1.0.4 leaks the expected JWT signature in an error… CVSS 3.0CRITICAL 9.8
Sources
- CVE-2025-46573 · CVE Program
- CVE-2025-46573 · NVD
- FIRST EPSS
- GHSA-8gqj-226h-gm8r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences