Information exposure in Next.js dev server due to lack of origin verification
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Passive
- Attack complexity
- Low
- Attack requirements
- Present
- Impact type
- —
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Partial Red Hat: 7 without a fix
Attack profile from CVSS 4.0 · CNA. Fix status from CNA, GitHub and Red Hat.
Summary
Next.js is a React framework for building full-stack web applications. In versions starting from 13.0 to before 14.2.30 and 15.0.0 to before 15.2.2, Next.js may have allowed limited source code exposure when the dev server was running with the App Router enabled. The vulnerability only affects local development environments and requires the user to visit a malicious webpage while npm run dev is active. This issue has been patched in versions 14.2.30 and 15.2.2.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| vercel | next.js | 13.0 to before 14.2.30; 15.0.0 to before 15.2.2 | 14.2.30, 15.2.2 | Patch available | CNA |
| — | next (npm) | 15.0.0 to before 15.2.2 | 15.2.2 | Patch available | GHSA-3h52-269p-cp9r |
| — | next (npm) | 13.0 to before 14.2.30 | 14.2.30 | Patch available | GHSA-3h52-269p-cp9r |
- next.js Vendorvercel Affected 13.0 to before 14.2.30; 15.0.0 to before 15.2.2 Fixed in 14.2.30, 15.2.2 Patch available CNA
- next (npm) Vendor— Affected 15.0.0 to before 15.2.2 Fixed in 15.2.2 Patch available GHSA-3h52-269p-cp9r
- next (npm) Vendor— Affected 13.0 to before 14.2.30 Fixed in 14.2.30 Patch available GHSA-3h52-269p-cp9r
Remediation
- Fix · CNA next.js (vercel) Fixed in 14.2.30, 15.2.2
- Fix · GHSA-3h52-269p-cp9r next (npm) Fixed in 15.2.2 Advisory →
- Fix · GHSA-3h52-269p-cp9r next (npm) Fixed in 14.2.30 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 10 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux 7 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Out of support scope |
| Red Hat Enterprise Linux 9 | Affected | No fix yet: Fix deferred |
| Red Hat Enterprise Linux AI (RHEL AI) | Affected | No fix planned: Will not fix |
| Red Hat Trusted Artifact Signer | Affected | No fix planned: Will not fix |
| streams for Apache Kafka 2 | Affected | No fix yet: Fix deferred |
Timeline
- 2026-10-02 Threatist record created from CVE-2025-48068
- 2026-10-03 Alias added: GHSA-3h52-269p-cp9r
References
More vercel Next.js vulnerabilities
- TI-2025-34861 Deserialization of untrusted data in Meta react-server-dom-webpack KEVCVSS 3.1CRITICAL 10.0
- TI-2025-21309 Authorization Bypass in Next.js Middleware CVSS 3.1CRITICAL 9.1
- TI-2025-34863 Deserialization of untrusted data in Meta react-server-dom-webpack CVSS 3.1HIGH 7.5
- TI-2024-31371 Cache Poisoning in next.js CVSS 3.1HIGH 7.5
- TI-2023-24914 Next.js before 13.4.20-canary.13 lacks a cache-control header and thus empty prefetch… CVSS 3.1HIGH 7.5
- TI-2026-32490 Next.js: Server-side request forgery in applications using WebSocket upgrades CVSS 3.1HIGH 8.6
Sources
- CVE-2025-48068 · CVE Program
- CVE-2025-48068 · NVD
- FIRST EPSS
- GHSA-3h52-269p-cp9r · GitHub Advisory Database · CC BY 4.0
- CVE-2025-48068 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences